Raspberrymatic integration connection problems


i have a problem with setting up my Raspberrymatic Configuration.
I am working on that problem the whole day but without success…

So I have sucessfully installed Raspberrymatic and it is working fine, i have already added a device and can communicate with it.
But when i try to get the Integration working, so i have the devices inside Homeassistant, nothing is really working.
I Installed the Integration in the HACS store and now i try to add it…

But i only get that the connection failed.

The Log says: “[custom_components.homematicip_local.config_flow] Unable to connect (<ProtocolError for de838cd8-raspberrymatic:2001/RPC2: 503 Service Unavailable>,).”

And the bootup of the Addon seems fine to me…

I hope someone can help me with that problem.

The Bootup:

In RaspberryMatic Settings-Control Panel-Configure firewall, can you check if everything is set to full access and that at least port 2001 is open.

Yes everything is full-access

Well, it’s definitely having problems talking to the add-in, so can you check that the RaspberryMatic add-in config looks like this:

I have done that also, exept for the “ssdpd auto-discovery (Extern)”, because the 1900 port is blocked by something else…

Actually, if the add-in and the integration are running on the same device you don’t need any entries here. You should click on “RESET TO DEFAULTS” and restart the add-on. Otherwise, make sure the the ports on the integration match what you have on the add-in. The error message de838cd8-raspberrymatic:2001 says the port is closed and you are using ports on the add-in starting with 4.

Okay i just resetted the default ports, but the error stays the same.
Actually when i do close the Firewall on the Rasperrymatic:

I get a different error. I cant really tell if that is good:
2022-09-07 18:24:25.586 ERROR (MainThread) [hahomematic.xml_rpc_proxy] (111, ‘Connection refused’)
2022-09-07 18:24:25.589 WARNING (MainThread) [custom_components.homematicip_local.config_flow] Unable to connect (ConnectionRefusedError(111, ‘Connection refused’),).

Also, see the instructions here for assistance https://github.com/danielperna84/custom_homematic

If you are going to use TLS ports (42001, etc) you will need to set TLS on the add-in as well. I would get it working with the standard ports first though.

Yes there is no need for me to use the TLS ports anyway.
I already worked this instruction up and down, but i really dont get where my problem is :frowning:

And really thank you for your support!

No problem :slight_smile: You have reset the RaspberryMatic Firewall to Ports Blocked - can you put it back to the way it was with Ports open & Full access.
Then in Home Assistant, go to Settings, Add-Ons, RaspberryMatic. You can then go to Configuration and press Reset to Defaults for the Network.
Next, restart the Add-in and wait for it to start up.
In Settings, Devices & Services, remove the Homematic(IP) Local integration and restart HA. Reinstall the Homematic(IP) Local integration and go through the configuration. If you have the ports setup correctly, then it should auto-configure itself once you enter the hostname, username and password.

Okay i have done that, also reinstalled the Homeatic(IP) Local integration but with no difference :frowning:
Still the same error:
2022-09-07 19:02:34.544 WARNING (MainThread) [custom_components.homematicip_local.config_flow] Unable to connect (<ProtocolError for de838cd8-raspberrymatic:2001/RPC2: 503 Service Unavailable>,).

This is strange, as I have installed this on several systems and it just worked. Can you give some information on your system - hardware platform, etc.

Also, make sure that you are not running the old Homematic integration as well, this could cause the port conflict.

Well this is my first Homematic install, so i guess there is no way that there are older Homematic inegrations.
What i was thinking about is: I am also Using Raspbee with deCONZ, could there be a problem with both Gateways?
I have Homeassistant installed on Raspberry PI 4 2GB.
Newest Version of HA is installed.
I use the Homematic Stick “HmIP-RFUSB-TK”
Is there more Information that could be helpfull for you?
I also found something in the Logs of the Raspberry Matic, which looks suspicious, but i dont know what to do about it:

OK thanks. That error message seems to mean that the RaspberryMatic configuration is corrupt. See if this topic is of any help: https://github.com/jens-maus/RaspberryMatic/issues/613

So the solution would be to execute “monit unmonitor HMIPServer” ?
If yes, im sorry to ask but where do i execute that?

I’m afraid that I don’t know :frowning: I suggest that you open an issue in the RaspberryMatic github: Issues · jens-maus/RaspberryMatic · GitHub and see if they can help.

1 Like

The used HmIP-RFUSB-TK isn’s capable of BidCosRF.
So “aktiviere Homematic (Bidcos-RF)” must be unselected when setting up the integration.
All logfiles ar fully normal.