Raspbian + Docker (HomeAssistant + HassIO Supervisor)

Tags: #<Tag:0x00007f3f1630e718> #<Tag:0x00007f3f1630e5b0>

Hello guys,

I’m doing a project at home and i’m using HA (of course).

For some reasons, i wanna keep full control of my docker environment, and share HA containers with others containers.

So right now, i have installed Raspbian with docker and used the official HomeAssistant image, all is running good.

I wanna now use the “hassio-supervisor” addon, to be able to use it on top on my HA installation.

I success to do it working, BUT he use internal conf for HA.
I didn’t found the way to “link” the supervisor to my HA installation.

I can move my HA conf folder to the supervisor folder, it’s working, but i loose the hand on all settings i put on my docker container. That’s a problem.

Do you know how i can do it working smooth ?

Thanks for your help !

Is this what you are looking for? Install Hassio without HassIO?

Thanks, i already found that and tried it.

My question is after that, how to set option for the “homeassistant” docker image ?

I have already docker with specific settings for HA, i just wanna HASSIO (supervisor) to be on top on my install.

I think it’s possible, as HASSIO works with docker containers … Just specify where HA folder is, and that’s all …

Here my configs for Docker :

services:
homeassistant:
container_name: Home-Assistant
image: homeassistant/raspberrypi3-homeassistant:latest
privileged: true
depends_on:
- influxdb
volumes:
- /srv/docker/hass/config:/config
- /etc/localtime:/etc/localtime:ro
expose:
- 8123
devices:
- /dev/ttyUSB0:/dev/ttyUSB0
- /dev/ttyACM0:/dev/ttyACM0
restart: always
network_mode: host
environment:
- TZ=Europe/Brussels

And working great !

Now wanna “plug” the supervisor …

services:
hassio_supervisor:
container_name: HassIO
image: homeassistant/armhf-hassio-supervisor
privileged: true
volumes:
- /etc/localtime:/etc/localtime:ro
- /var/run/docker.sock:/var/run/docker.sock
- /var/run/dbus:/var/run/dbus
- /srv/docker/hassio-supervisor:/data
expose:
- 8123
environment:
- TZ=Europe/Brussels
- SUPERVISOR_SHARE=/srv/docker/hassio-supervisor
- SUPERVISOR_NAME=hassio_supervisor
- HOMEASSISTANT_REPOSITORY=homeassistant/raspberrypi3-homeassistant
security_opt:
- seccomp:unconfined
- apparmor:unconfined
restart: always
network_mode: host

But not working …

1 Like

Hello,
Any news ?
I’m trying to do the same … ^^
Thanks