Raspi 4 - SSD - Google Wifi - HA unavailable


I have recently moved from an SD card to an SSD drive, but ever since I seem to have a recurring issue, my Raspi with HA and everything that is connected to the same switch (Ikea Tradfri, Tado) goes unavailable at random times. It could be 5 days it could be 2x in 24 hours.
The only way to get it all back up is to replug the power to the Raspi after which it all comes back online.
I have tried:

  • putting more distance between the Raspi+SSD and the other components, but to no avail. Currently about 1m (±3ft) between them.
  • Plugging the SSD in to the USB2 port as I understand USB3 can create interference on the 2.4GHZ band
  • Monitored CPU temperature: steady 65°C
  • Monitored Memory usage: steady 27%

Details about my set up:

  • Google Wifi set up
  • Raspi with HA, Tado and Ikea Tradfri hub are wired to the Google Wifi pod with Netgear switch
  • Official Raspi power supply
  • The Google wifi pod connects via mesh to the Google wifi main pod (router)
  • Raspi 4 with Kingston SSD and Startech USB 3.0 SATA cable

Anyone got any tips or ideas on how to resolve?


So, it’s the bridge itself which becomes unavailable?
Or the devices linked to the bridge?

Bridge itself, just like it’s the Tado bridge that loses connection.
Basically it seems any device connected to the wifi puck loses connection.

And the RPI is connected to the same netgear switch?
And the RPI cannot talk to the, e.g., tradfri anymore (which are connected to the same switch)?

Exactly, connected to the same netgear switch; which is connected to the same Google Wifi puck.
And they all seem to be unavailable: the raspi, the tradfri hub and the tado bridge.

As soon as I replug the raspi, they all come back online again.

Last (hopefully :wink: ) question.
From which point-of-view are those “unavailable”? Some other device on the wifi?

They are unavailable through their respective apps, yet they still seem to be running (when I check the actual device).

And just quickly unplug/plug the RPI4 makes everything working again? Strange…
You wouldn’t happen to have a dhcp server on the RPI, do you?

Very strange indeed.

For nearly all my devices I have fixed IPs, incl the Raspi. And the DHCP is running on the Google wifi, not on the Raspi.

even though the power rating of the SSD would not make you think it is over powering the PI, some of the dev’s find it not advisable (“asking for trouble”) to use it without a powered hub. I didnt read it in your setup above, but to be sure: do you use a powered USB Hub?

Because that could easily be the cause for the RPi4 not rebooting (host that is, core should restart without issues)

Relying on Wifi for the RPi connection to the network might be considered likewise though…


not sure how this relates to the described issue? I don’t think the issue is the booting of the core or other. It’s the impact on all other connected devices (potentially).

Or am I reading your response incorrectly?

Yes. You have an issue with
RPi and Ssd
System going unavailable
Can not reboot host without unplugging

All identical to a lot of reports with users having a powered usb hub back powering the Rpi.

If not, forget about it.

Do try to connect a Lan cable though if WiFi isn’t stable. Always really.

Additional info: I moved it over to wlan yesterday, rather than wired via UTP. It went unavailable this morning, but at least the ikea hub and Tado bridge remained available.

I looks like the RPI sends a mess on the network, but it’s very difficult to guess the root cause.

If you can hook a display and keyboard to it, you could at least reach the OS (assuming it’s actually still running) and assess the state of the network.

Attached a powered hub. Still goes offline.

Is there a way for me to figure out what network traffic is being generated by the raspi? I can see that it’s generating quite a bit of network traffic, but I have:

  • 2 RTSP camera’s running
  • Google Nest doorbell stream
  • My database is on my Synology NAS
  • I’m running AdGuard for 2 android devices
  • I run an MQTT server with quite a few mqtt devices connected

Well, there is wireshark, but it’s quite technical.

RTSP will typically generates a lot of traffic. It’s maybe worth disabling the cameras for a while to assess whether it improves the situation.

sorry to hear, ruled that one out…

I’ll just leave this here if someone would run in to similar problem.

The issue has finally been identified, Adguard and Google Wifi aren’t playing nicely together (settings need to be tweaked) and Adguard seems to block the router due to too many requests (found it in another post on Reddit https://www.reddit.com/r/Adguard/comments/nbb5i2/adguard_home_and_google_mesh_wifi_not_working/?utm_medium=android_app&utm_source=share).

So for now I’ve disabled adguard en my RPi seems to run stable again. I’ll have to look more in to the adguard whitelist options.

Crashes are unrelated to either Google Wifi nor AdGuard but to the HassOS version.

Ref: Host crashes and goes offline at random times · Issue #1336 · home-assistant/operating-system · GitHub

Anything after HassOS 5.4 crashes at least once every 24h. Downgrading to 5.4 has resolved the problem for me at the moment. I’ll monitor the GitHub issue to know if I can update again or not.