Reboot loop after update OS 12.3 core 2024.5.3

Just a heads up.

Running on a RasPi 3 for 2+ years very reliably.

I thought I’d mention that after updating to the above versions yesterday, HA is now in a reboot loop. I can watch the kernel boot, HA CLI comes up and I end up at an “ha >” prompt. a minute or so later I start seeing some errors such as “Failed to change fw-clk-arm frequency”, “timeout wating for hardware interrupt”, and an indication of r/w errors. Eventually something triggers a reboot and it all begins again. Clearly there’s something wrong with hardware. Hoping it’s just the SD card.

Going to take it offline and try to recover backups and reimage.

1 Like

Than perhaps a more appropriate title for the post is needed since it has not been proven (yet) that it was the result of an OS upgrade.

It’s looking more and more like one of the two Bluetooth devices (hci0) is dead. It was coincidental to the upgrade.

Hi
I has a same error with rPi3b+ and OS 12.3
Rebooting along 8-10 times in a day.

Very sad.

Going back to OS version 12.2 all the problems were solved and the rPi3 stopped restarting by itself.

In Terminal:
has update --version 12.2

UGH I’ve wasted a week dealing with this same issue. Fresh install of 12.3… whenever I do ANYTHING to setup z-wave using the Z-Wave JS or Z-Wave JS UI add-in… everything crashes and then goes into a reboot loop. Lots of scary errors on the console, but the most consistent is mmc0: timeout waiting for hardware interrupt. I’ve swapped pi’s, sd’s, usb extenders, usb ports… always the exact same issue at the exact same place.

i’ve just now decided to try a fresh build with 12.2 instead and so far … no issues. too early to declare victory but … so far so good. i have a live instance that I built with 11.x and have upgraded through to 12.3 and no issues so far (fingers crossed) – the only difference is I haven’t updated that instance to Core 2024.5.4 which ships with 12.3… so maybe it’s Core 2024.5.4 not HAOS 12.3?

/frustrated!