Received invalid command: device automation/trigger/list

The complete error is:
Received invalid command: device_automation/trigger/list
9:30:13 PM – websocket_api (ERROR) - message first occurred at Invalid Date and shows up 11 times

Google hasn’t been kind in finding an answer. I noticed an issue when I tried to create an automation and selected a trigger device. There were no trigger options on the device only ‘Unknown trigger’. I also had issues with automations.yaml and it seemed to become corrupt - wouldn’t open through file editor/nano/samba so I deleted and recreated a blank file.

Would love to not have to start over but it wouldn’t be the end of the world.

Thanks in advance for any assistance and/or telling me where else I should be looking.

System Health

arch armv7l
dev false
docker true
hassio true
os_name Linux
os_version 4.19.106-v7l
python_version 3.7.6
timezone America/Los_Angeles
version 0.107.0b6
virtualenv false

Sounds like you may have a corrupted SD card. See if you have a spare and recreate

That’s not the complete error - please click on the Load Full Homeassistant Log button and copy the actual error message, which will be several lines long (just one copy will do, don’t need all 11 occurrences)

Thanks for taking a look.

Log Details (ERROR)

Logger: homeassistant.components.websocket_api.http.connection.2984872272
Source: components/websocket_api/
Integration: websocket_api (documentation, issues)
First occurred: 8:51:06 AM (1 occurrences)
Last logged: 8:51:06 AM

Received invalid command: device_automation/trigger/list

Hi, that’s still not the output that’s needed, sorry. You need to click on the big blue button “Load Full Homeassistant Log” then scroll through the output to the time of one of the occurrences and grab the whole thing.

The full error will look something like…

ERROR (MainThread) [homeassistant.helpers.entity] Update for sensor.u_s_air_pollution_level fails
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 936, in _wrap_create_connection
    return await self._loop.create_connection(*args, **kwargs)  # type: ignore  # noqa
  File "/usr/local/lib/python3.7/asyncio/", line 958, in create_connection
    raise exceptions[0]
  File "/usr/local/lib/python3.7/asyncio/", line 945, in create_connection
    await self.sock_connect(sock, address)
  File "/usr/local/lib/python3.7/asyncio/", line 473, in sock_connect
    return await fut
  File "/usr/local/lib/python3.7/asyncio/", line 503, in _sock_connect_cb
    raise OSError(err, f'Connect call failed {address}')
TimeoutError: [Errno 110] Connect call failed ('', 443)

I ran an update in hopes that would clear something out but no luck. I’m now seeing a couple devices as unavailable. Is this all just a sign that I need to start over and restore from a snapshot?

2020-03-18 08:51:06 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.2984872272] Received invalid command: device_automation/trigger/list

Ha - I can’t get the attachment to load :see_no_evil:

In all honesty it’s probably an external service that you’ve set up to speak to homeassistant that is sending either outdated credentials or a wrong format message.

What external services are you using? Ifttt maybe? Or a device tracker?

I get the same error after updating to version 107 today. Now I cant build any automations because when i select a device there are no triggers to select.|690x318

Updating to 0.107.1 seems to have resolved the automation issue. Hopefully my zigbee will start working again in the next update or two.