Recent issue with the Subura Integration

I have noticed recently that the subura intergration appears to be broken. Did subura change their API maybe?

2022-02-11 10:50:08 ERROR (MainThread) [subarulink.connection] RequestInfo(url=URL(''), method='POST', headers=<CIMultiDictProxy('Host': '', 'User-Agent': 'Mozilla/5.0 (Linux; Android 10; Android SDK built for x86 Build/QSR1.191030.002; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/74.0.3729.185 Mobile Safari/537.36', 'Origin': 'file://', 'X-Requested-With': '', 'Accept-Language': 'en-US,en;q=0.9', 'Accept-Encoding': 'gzip, deflate', 'Accept': '*/*', 'Content-Length': '156', 'Content-Type': 'application/x-www-form-urlencoded')>, real_url=URL(''))

2022-02-11 10:50:08 ERROR (MainThread) [subarulink.connection] ('<!doctype html><html lang="en"><head><title>HTTP Status 404 – Not '

 'Found</title><style type="text/css">body '

 '{font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b '

 '{color:white;background-color:#525D76;} h1 {font-size:22px;} h2 '

 '{font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color:black;} '


 '{height:1px;background-color:#525D76;border:none;}</style></head><body><h1>HTTP '

 'Status 404 – Not Found</h1><hr class="line" /><p><b>Type</b> Status '

 'Report</p><p><b>Description</b> The origin server did not find a current '

 'representation for the target resource or is not willing to disclose that '

 'one exists.</p><hr class="line" /><h3>Apache '


Seeing the same. Deleted and tried to re-add the integration, but that now fails with a “Failure to connect” message. The underlying Python package however still works.

I opened a bug report here:

Please feel free to contribute

Thanks at least now I confirmed it is not just me. Wonder if the underlining package needs to be updated in the integration.

Hey @hagak and @nanobra1n - are either of you still using the Subaru integration? I noticed my instance can no longer connect. It was working fine since setup and now shows a red error on device screen and in the logs says the integration isn’t ready yet and shows our registered Subaru email address.

I’ve tried reloading the integration without success. Curious if this is a global issue or something went south on my side…


I actually just noticed that this morning. I think it is a global issue.

1 Like

It worked up to a couple of days ago for me. Someone opened already an issue for it:

The underlying subarulink python package also doesn’t work, but the information on is available, so it looks like Subaru moved things to a new home

1 Like

Thanks to both - hope Subaru didn’t break things permanently- really appreciated the hard work that went into the integration

Any updates on this—is it working again? I haven’t setup the integration but really want to. Thx

It is not currently working for me. I had it for a few days, but starting last week it looks like they’ve shutdown the starlink service in favor of MySubaru. I think we’re going to be waiting for someone to figure out the MySubaru API before the integration will work again.

I tried this again today (3/31) and it seems to be working again. I have access to my vehicles info and locks. Not sure how long it’ll last but I’m excited.