Recently updated zwavejs2mqtt to 0.32.2 and now it won't connect

I am currently using the zwave js integration with the zwave js add-on to manage my z wave devices. I was using zwavejs2mqtt as a control panel only to set parameters for some devices.

I recently updated zwavejs2mqtt from 0.32.1 to 0.32.2 and it stopped working with the error

Driver: Failed to open the serial port: Error Resource temporarily unavailable Cannot lock port (ZW0100)

I tried to roll it back using the backup created before the update but its still giving me the same error. I’m at a loss on how to get this working again. Also while trouble shooting, all of my batter devices lost their config in zwave js and how just show up as “Node xx” in the device list. Any ideas how I might have messed this up and how to fix it?


You can’t use both add-ons at the same time. Pick on or the other, but not both.

So it was my impression that you could use zwavejs2mqtt with mqtt disabled in control panel only mode on top of z-wavejs addon. This is what I have had running successfully for the last few months. Is understanding not correct?

That’s incorrect. The integration communicates with either add-on. With both add-ons running they are fighting for control over the USB stick and interfering with each other. Sounds like you’ve been lucky up to this point, or haven’t noticed issues. If you want the control panel, then stick with z2m.

1 Like