Recorder fails with 8.x upgrading from 20221.7.7

I have tried upgrading from many previous backups, but recorder failes to start, so I do not have any history or energy.
I really do not want to delete db2 or whatever. Any ideas?

It sounds like your database didn’t restore properly, it’s not an uncommon problem that backed up databases restore as corrupted because they were backed up while open. It’s the primary reason, other than performance, that I switched to MariaDB.

sniff :frowning: thanks


1 Like

I’m running a 100gb MariaDB on a NAS with 2 year full resolution data. Works great, especially with the recent improvements to history charts.

Well I pulled the trigger and made the change. Have not tried a restore yet

@PeteRage 100gb ?? My VM is only 2gb with 25% used

100gb of mariadb data on disk.

Out of curiosity (cant watch the video currently) Will it migrate existing data or will i be starting from scratch. Title suggests the former?

No history starts over. In my case it was gone anyway

will have to try to restore a backup and see if it stays now

should i manually stop the db before backups?

I always did. I wrote a script that stops HA, copies the DB elsewhere and restarts HA and it has worked for me.

where is the database. I di not seem to find it in file editor