Recorder - purge_keep_days - invalid config - why?

I’m trying to make the history bigger, that by default stores 10 days only. In my first install years ago there was no such limit, which I really enjoyed.

In configuration.yaml I try to set it for one year with the lines:

  purge_keep_days: 365

I’m getting the following error when checking the config:
Invalid config for [recorder]: [themes] is an invalid option for [recorder]. Check: recorder->recorder->themes. (See /config/configuration.yaml, line 25).

I also tried different values and copied straight from the Integrations-Description page. No luck.
How to get it right?
Thanks for your help.

Can you show more of the config including themes? It looks like you have specified themes under recorder…

1 Like

Hi @DavidFW1960, sure:
you were right!
I had recorder before themes.
I just now noticed that themes is a child of frontend. Now I put recorder after themes and there is no more error.
Thanks a lot!

1 Like