Recorder.purge service call not working

I know I am entering something wrong in the services panel and google is letting me down on the json to make it work.

Service: recorder.purge

With this json:

    "keep_days": "1"

It is not starting the purge.

Help please?

Works for me, with and without the quotes around the number.
Since 0.61.1 no events get purged

2018-01-17 07:47:29 DEBUG (Recorder) [homeassistant.components.recorder.purge] Deleted 938 states
2018-01-17 07:47:29 DEBUG (Recorder) [homeassistant.components.recorder.purge] Deleted 0 events
2018-01-17 07:47:29 DEBUG (Recorder) [homeassistant.components.recorder.purge] DB engine driver: pymysql

I am running 60.0 and it is definitely not working for me.

I’m running 0.60.1 and it doesn’t appear to be working for me either.
Disk Usage is at 100% so i’m not sure what to do.

There was a bug with recorder purge that got fixed in 0.62.

I can verify that 62.0 fixed it!

Ahh thats helpful, trouble is it won’t let me perform the upgrade as the disk is full…

Shut down with “hassio homeassistant stop”, delete the database and then “hassio homeassistant start” and upgrade?

1 Like

That’s worked thank you, i wasn’t sure of the implications of deleting the DB and how much config type data is stored within it.

I am still working on the learning curve as well! :slight_smile: It is my understanding that config data is all in the .yaml files and that state and historical data is contained in the database. So… as long as home assistant is stopped the database can be deleted and will be rebuilt with current data once the program is restarted. The key is that your historical data will be lost. I have mine set up to purge every day and to keep 2 days worth of data. The unit must be running for 1 full day for that to work, if you restart homeassistant that counter resets to 0.

You are welcome, it is my goal to help where I can because I have been there as well, not that long ago.

i still see this, and the file just keeps growing…

any thoughts/hints?

Are you using the recorder purge settings?


#db_url: !secret db_url
purge_interval: 2
purge_keep_days: 3
    - sensor
    - switch
    - media_player
    - light
    - device_tracker.m
    - device_tracker.etc
    - device_tracker.etc2
    - automation
    - weblink
    - updater
    - sun.sun # Don't record sun data
    - sensor.last_boot # Comes from 'systemmonitor' sensor platform

also tried it through the dev-tools, hence the error as mentioned in the other thread …

Looks like it is not working in 78.3. recorder.purge is not working at all.

Also it is not working on 79.2 either

did you guys try a manual purge by calling the service in the frontend (recorder.purge) ? at least that worked for me…

I tried multiple times and nothing happened :confused:

Ok. Purge is working.

But you need to ran dB vacuum manually :).

More details:

any hints how to from the command line Hassio…?