Recover existing backup from boot SD card?

Hi all, just completed installation after a month of working on it over weekends.

My setup is a Raspberry Pi 4B with external access via my personal domain.

Today, my installation became inaccessible from anywhere. I plugged the Pi into my monitor, and with the help of existing forum posts, accessed the CLI and found that my Pi couldn’t access the network because it thinks there’s no cable plugged in (I’ve now tried 3 cables and every port on two switches, so the physical networking is fine). I restored to my last backup with CLI and restarted, the web UI came back for a minute, then back to no connection.

I’m now stuck in a loop of restoring to a backup with CLI, booting Hass and then it dropping out again after less than a minute. I’ve not changed any router settings or networking settings in Home Assistant recently.

Where can I go from here?
Is my SD card probably past its write cycle limit?
How can I pull the backup from the Pi in the 15-30 seconds it has network access? Can I do this with the CLI?
Should I pull the SD card and find the backups stored on it from my laptop?
Should I install home assistant on a new machine?

Thanks for any help you guys have. I really can’t afford to start again now, I’d almost finished my intallation and was planning on setting up google drive backups this weekend, now it’s impossible.

Can you access your log file? No clue about the problem when looking at the logs?

You can go Settings > System > Backups then select your backup from the list, click the 3-dots menu and select Download… But it will be hard to have all this process done in less than a minute (the download itself will take a wile based on the file size).

It’s hard to believe the problem is in your Raspberry Pi. It is quite common to hear about problems into the SD card, not on the RPI, so I would put some coins that the problem is not related to the RPi itself.

Thanks for the reply Ed, I solved this by installing a Linux reader on my laptop to get the most recent backup, then reinstalling with a new SD card. I tried a fresh install on the original SD and it didn’t work again - must’ve been a faulty or completely used SD card.


1 Like