Recurring Issue where Settings - System and other vital pages error out

Hello, I have been experiencing a (new to me) issue where several vital parts of Home Assistant stop working. Running for 3-4 years now with essentially no issues on a RPi4, now on USB flash drive.

My issue is this: I’ll notice that some automations have stopped working (not getting notifications for certain events that I would expect automations to be triggered by). I check my home assistant instance. First thing I notice is that in my Settings page, the usual update for the latest version of Home Assistant (most recent I saw was 2023.7.1) is no longer showing at the top of the settings page. This for me is a key indicator that something has gone wrong with HA. I then try and click the System Settings page button. I get a page that says “Error while loading page system.” Then pretty much every page on this settings page will return the same error, aside from the automations page which will load.

I notice as well at the same time that my Z-Wave Integration will not load. Going to the configuration page for z-wave also throws an error: “Error while loading page z-wave.”

Finally, and perhaps most importantly, I am unable to restart the system from inside the Home Assistant instance. I try to click the restart button, and nothing happens. I am unable to access any pages that might let me restart the hardware a different way as a result of these issues above that I have described.

So, in this case, I am far away from home for a while, with a malfunctioning home alert/management system, with no way to fix.

Anyone else ever run into this issue, or idea for steps to diagnose and repair? I’ve tried pulling logs, but they are so heavily verbose to the point where I’m not sure I could ever diagnose the issue. And, in the system’s current state, I cannot even access the place where logs are stored in the UI.

Not an RPi person, but I would guess RAM of DISK issues, most likely disk corruption.

Just an update. I updated my system from 2023.6 to 2023.7 and it has had no issues. I’m guessing it was OS-related, which is disappointing

I had this same issue on 2023.7.1, which stayed that way until today since I never really used any of those settings. I power cycled all of my IT equipment including my raspberry Pi 4 that was running HA and the settings pages all came back, not sure what triggered it. I immediately created a backup and updated to the latest 2023.12.4 Core. I also update the OS to 11.2 from 10.3. My OS is on an SSD, not sure if that helps.

Yeah i’ve found this is a recurring, unsolved, and unreported issue that persists even now in the latest iteration of home assistant. Power cycle always fixes it. I use an SSD now as well and have had it happen both when I used a micro sd and when I use an ssd. Had to put a smart switch in homekit outside of home assistant that allows me to power cycle my rPi remotely.

I’m having this exact same issue, started after I migrated my instance from an SD Card to an SSD. Power cycling is the only temporary fix. Did you find a solution?