Reduce my history size

I’ve been trying to reduce the size (time to render) of the history and get rid of stuff I don’t care about but i’m having some issues.

I tried to remove the date time from the history. That didn’t seem to work.
I also tried removing entity_globs from recorder that didn’t see to work either.

history:
  exclude:
    domains:
      - automation
      - updater
    entities:
      - sensor.last_boot
      - sensor.date_time
      - sensor.date
      
recorder:
  purge_keep_days: 5
  exclude:
    entities:
      - sensor.date
      - sun.sun # Don't record sun data
      - sensor.last_boot # Comes from 'systemmonitor' sensor platform
    #entity_globs:
    #  - sensor.weather_*

Did you delete the home-assistant_v2.db file in config and restart server after making this configuration?

Deleting the history and restarting solved the issue of the graph. Thanks @sheminasalam

2nd part, it seems I cannot use the

entity_globs:
      - sensor.weather_*

I get this error when I check config

Invalid config for [recorder]: [entity_globs] is an invalid option for [recorder]. Check: recorder->recorder->exclude->entity_globs. (See /config/configuration.yaml, line 56). Please check the docs at https://home-assistant.io/integrations/recorder/

I get this error when I try to exclude using the entity_globs

recorder:
  purge_keep_days: 5
  exclude:
    entity_globs:
      - sensor.time*
    entities:
      - sensor.date
      - sun.sun # Don't record sun data
      - sensor.last_boot # Comes from 'systemmonitor' sensor platform
      - sensor.date_time
      - sensor.time
      - sensor.time_utc

The reason I want to use the entity_globs is I want to filter out all the entities with NodeID, etc

i copied your recorder config to mine and there is no issue popping up in m config check. It seems very strange.

What version are you running? I"m running Hassio on a Pi4…

image

Just did a upgrade to supervisor-2021.01.4

The config check’s valid. Will reporrt back if I can filter on the globs

I Just got the same issue.

“”" Configuration invalid
“”" Invalid config for [recorder]: [entity_globs] is an invalid option for [recorder]. Check: “”"recorder->recorder->entity_globs. (See /config/configuration.yaml, line 12).

:frowning: … i tried to follow the guide, to exclude

"recorder:
" entity_globs:
" - switch.countdown_*
" entities:
" - sensor.stats

Succeeded with below syntax:

recorder:
exclude: = 2 dash in
entity_globs: = 1 tab in
- switch.countdown_* = 1 tab+2 dash in
entities: = 1 tab in
- sensor.stats4 = 1 tab+2 dash in

I did this

recorder:
purge_keep_days: 0
include:
domains:
entities:

No idea how to check the size of the database?

To reduce the size after purge, you should also tick " Repack "
In file-editor( add-on ) you can see the size of the " home-assistant_v2.db "
Or you can install Samba Share ( Add-on )