Reformat SD card after HASSIO?

How do you all reformat/reuse SD cards after using them for HASSIO? When I put my card into the USB reader on my PC it opens 5 drives (E, F, G, H, and I) with only the E drive being readable. What tool are you all using to delete all these partitions and reformat the card back to stock?


you can follow this to get it back to a normal SD card. I did it just the other day.


Google MiniToolPartitionWizard and use that to delete all the partitions on the card and create one new one. Make sure to apply changes when done.

1 Like

Just for future info, the tool used in the link I provided is already built into Windows by default so no need to get anything new, works perfectly and super fast.

I’ve had nothing but trouble using that.

Actually - my mistake - I thought it was using the graphical disk management tool in Windows. That would work fine (as long as you don’t make a mistake and select the wrong disk LOL)

Tried all this, did not work. Anyone have any luck?

same here no luck with diskpart

Occasionally, I have an SD card that even Diskpart can’t clean. Here’s two things you can try:

  1. Get a camera that uses an SD card, and tell it to reformat the SD.
  2. Format it in Linux. I’ve done this once with a particularly stubborn SD card.
    In a terminal enter: fdisk /dev/sd_x_
    where /dev/sd_x_ is your SD card device.
    You can then delete all existing partitions on the device by typing d, (repeat as needed)
    You probably don’t need to add new partition and format it if you plan to burn a new image.
    cfdisk is also another viable tool, which is basically fdisk with a greatly improved user interface.

Hope this helps

1 Like

Have the same issue, already bricked 2 sd cards! I tried with many windows methods, I tried with linux, with direct dd commands… All of them appear to be working, but after they say successfully cleaned or whatever, my drives are all intact.

  1. Right click on the Start button.
  2. Click Command Prompt (Admin).
  3. Type diskpart.
  4. Type list disk.
  5. A list of disks will be displayed. Note the number of the disk you wish to remove.
  6. Type select disk n (Replace n with the disk number with the partition you wish to remove).
  7. Type list partition.
  8. A list of partitions will be displayed.
  9. Type select partition n (Replace n with the partition you wish to delete). In this case you must do this with all partition.
  10. Type delete partition override.
  11. After you remove all partition, go to disk manager and format
1 Like

Sanity check. If the reader is locked for the write operations. The diskpart will have an I/O error. Make sure you shift the lock up on the SD card-reader to have both read-write access.

Has anybody found a way that works?

I have tried using linux gparted, linux disks, windows disk management, minitool, diskpart (windows and linux).

Same here… Tried all these tools, tried flashing a new image use etcher nothing changes in the card partitions. Seems crazy there isn’t a way to clean this.

Windows mini tool always works for me… I last used it yesterday for one of my Pi’s. I just delete the old partitions apply then create a new partition and apply and I can image it…

Windows disk management should do the job.
You have to right-click on any existing partition/volume of the disk and delete it. After that you can create a new volume and format it or use the card directly with Etcher.

1 Like

I think the problem is this card was pre- Hassos… was still using Resin-Os version.

Nothing works :frowning:

How about FDISK in Linux? Just delete all partitions. I did this with an uncooperative SSD last week.

Delete all partitions (start with the last one) as described above (Windows), and then create a simple volume.
That’s how I do it every time and it works.

1 Like

As long Windows recognize them the partitions, it shouldn’t be a prob.
Just delete them.

Thanks for all the suggestions… I’ve never encountered behavior like this before as well but have tried using fdisk in linux, and diskparted in Windows. Strangely they report “success” when i delete the partitions but when listing them again (after saving in fdisk) they remain unchanged.

The Windows Disk Manager UI tool has no luck and just does nothing if i attempt to delete the volume.