Release 0.88 Edge Broswer stopped allowing me to sign in

I use the edge browser only for Home Assistant, I like the way my floorplan renders on Edge as opposed to Chrome & Firefox…

After upgrading to HA release 0.88 I can no longer sign in.
I deleted files auth, auth_provider.homeassistant & onboarding on my rPi, cleared the cache but can’t get pass the logon screen. Works fine on FireFox & Chrome

Any ideas?

Here’s the error message I get:
Logging in with Home Assistant Local .
Error: Message format incorrect: required key not provided @ data[‘client_id’]

Same problem for me, tried to login from another PC with Firefox and I just can’t. Same error message.

Existing logins from already used devices works for me but from a new device I got the same error

Anyone have a solution of how to fix this?

Same problem since update to 0.88.1 on firefox. I can still login with my android cellphone but each time I log in with my cellphone I get a notification: Login attempt failed, Login attempt or request with invalid authentication.
Login don’t fail so it’s strange.

Good News, kind of!
I updated to 0.89.0b1 and I can now log into the Edge Browser, great
however, I can’t resolve any of the lovelace custom cards that use custom updater.

I’ve cleared the cache, restarted the pi, reloaded the screen.
Is there something else I need to do?

Thanks for reporting this glitch.

I thought I my testing of 0.88.1 was done and I was ready to upgrade to it from 0.80. However, I didn’t bother to check it using MS Edge. I can confirm I get the same error message.

Oh well, 0.89 is just days away …

I have the same issue with Microsoft Edge.
Internet Explorer won’t load UI properly.
No issues with Google Chrome.

FYI, I can now log in to 0.89 using Microsoft Edge. However, one may have to clear Edge’s cache first otherwise it may still fail to connect.

0.101.0 still cannot login with Edge of a fresh Windows 10 install…

File "/usr/src/homeassistant/homeassistant/auth/providers/", line 290, 
in async_step_init user_input["username"], user_input["password"]
KeyError: 'username'

Firefox and Chrome works fine.

I switched to Edge Canary and works great