Remote Access to HA

I’m trying to access to my HA portal via internet (outside my house) but after open port forwarding on my modem and check the port forwarding says it’s open but when I try to enter via my ip and port 8123 i can’t access. I already tried duckDNS and doesn’t work.
Thank you for your help!

Are you accessing it from outside your LAN? I.e. On your phone without wifi? Some routers don’t like external requests from inside.

Can you check your router logs? See if there are any entries related.

I assume you got your public IP from your router or a “what’s my ip” website and are following that with “:8123”

Finally post up your port forward settings. Maybe there is something simple we can help with.

I setup my port forwarding as follows and it works set external port to 80 forwarded to internal port 8123 set external port to 8123 forwarded to internal port 8123 set external port to 443 forwarded to internal port 8123

I’m trying to access via LAN and using the LTE connection and doesn’t work.
I already checked the router logs and doesn’t display info in System logs and event logs.
Here is a screenshot of my settings on port forwarding. Do you see something wrong?
Thank you!

Few questions:

  • Is that the correct IP address of the HA server?
  • Have you tried hitting it directly on the Public IP address just to test it?
  • Does Duck DNS respond to the right Public IP address when you do an NSLOOKUP? Could be broken DNS.

Check your Public IP:

dig +short

See if they match:


  • Does your ISP block any of those ports? Some do.

It looks ok to me. Have you tried connecting using your external IP instead of the dnsname? Get that to work before you move on to handle it with duckdns.

You can usually check your external ip on the router or with some external service and try connecting to it from your phone. Don’t forget to use https:// so the browser knows to use SSL (you do have encryption on homeassistant, right?)

You could also try to forward on other start port numbers, like 443, 8080

As a sidenote, you only need to forward TCP, no reason to forward UDP here.