Remote access with DuckDNS not working (January 2023)

Hi all. I am new to HA, I installed it in a Raspberry Pi 3+ Model B last week.
Since then, I have been trying to obtain remote access, but it is not working. I tried different configurations and checked over different posts.

Particularly now, I have followed the DuckDNS tutorials, and my current configuration includes the following four points:

  1. The duckdns add-on, version 1.15.0, configured as follows:
    [See image A below]

  2. The logs of the duck dns add-on says OK:
    [See image B below]

  3. The configuration.yaml file:

# Loads default set of integrations. Do not remove.

# Load frontend themes from the themes folder
  themes: !include_dir_merge_named themes

# Text to speech
  - platform: google_translate

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

#  api_key: NPDI83XDOH7I9VRL
#  id: 1955885
#  whitelist: sensor.yr_temperature

  username: !secret sonoff_username
  password: !secret sonoff_password
# http:
#   use_x_forwarded_for: true
#   trusted_proxies:
#     -
# alexa:
#   smart_home:

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  1. The ports forwarded in my router:
    [See image C below]

My public IP since last week has not change. I can access my HA from
but when I try

the page does not load. Using google chrome, it says ERR_CONNECTION_REFUSED or ERR_CONNECTION_RESET.

I checked that the ports are opened with
Any ideas? Thank you for your help.
Best regards

When you go to the DuckDNS admin page for your domain, does it report the correct public ip of your router?

Also you can delete the port 80 and 443 forwarding rules. They are not needed for the url you are using and the less ports you have open the better.

I think DuckDNS might be down currently. I can’t even access their website right now.

Yeah you’re right:

Are there still issues with duckdns? I can get to my instance when I set external_url and ssl files to default (then with simple http://<ip>:8123), but it wouldn’t work through duckdns.

Thank you all for your replies:

Yes it does, I forgot to mention that.


I can log in as usual, I obtain the same result as this previous week.

I have not done this. What do you mean?

May it be something with the IPv6?
Thanks again

I normally have it set to duckdns domain, as this was the only way I could get my setup to work. I’m running docker on debian host, so there were few additional issues.

I’m pretty sure it doesn’t matter in your case, as I didn’t need it when I used HA OS

A quick update on my side (may not be necessary about the issue)

The problem seems to only be with duckdns. In a happy little accident (received a notification from HA, while I thought it was unreachable) I discovered, that my instance works without any issues (well, apart from being inaccessible from outside world).

There’s no need for removing external_url or any of the ssl variables (if you’re ok with browser security warning).
In my case while I can’t access the https://<subdomain><port>, https://<local_ip>:<port> is still accessible.

For now I’m able to access HA from a local network without any issues and I hope that until tomorrow, duckdns will be fixed.

I do not think that has to do with my issue then.
Shouldn’t I be able to access from https://<my_public_ip>:8123 anyway?

Hi @pacjo , I got the same issue since January… but it was working normally before.
and yes, if you use public_IP it works.
Did you fix it?

BTW, now it just works and I changed nothing! But it also worked last Tuesday.
I do not know why this happens, but I am starting to believe the problem is with DUCKDNS!

And today it doesn’t work :confounded:

Hi, is anyone else having issues with DuckDNS all of a sudden not working anymore on home assistant for the last week or 2? I did a fresh install opened all the ports etc and no luck. I’m also not sure if it is maybe my TP-Link Deco M4 routers and maybe a problem with the port forwarding. It was all working before and just stopped all of a sudden. I’m not sure if it was after an HA version update or after my routers app updated.

I have HA setup on an IP address outside of my DHCP scope and when I delete the rules and try re-create them it only allows me to create the rules for devices that are inside the DHCP scope on the routers. There also isn’t a firewall on the deco app so it can’t be that.
any ideas?