Remote ssh hassio login not possible?

my Hassio/duckdns/letsencrypt install works fine. I can acces it from everywhere, and can ssh into [email protected]

i cant however login to ssh [email protected], or [email protected]:8123 for that matter. The latter should be expected, but the root@duckdns is a bit of a letdown. Every once in a while we need to reboot through ssh, and when working from another place than home, this is a nogo right now.

What am i doing wrong?


Assuming you have your port forward in place on your router, and are attempting this from an external source (a lot of routers do not allow for ‘hairpin NAT’), there shouldn’t be anything blocking it from the side. I don’t see why this wouldn’t work

i do have port forwarding, as instructed per duckdns. and yes, from an external source.

even tried the public ip address of my router, didn’t help either…

would my VPN be of any hindrance … both on my mac, and or iPhone?
if i try from Shelly on iPhone, i see that i can add a key which i don’t have. I do have certificates set up though, and those i cant add in Shelly.
No sure if these certificates are used when shelling in, or wether they are only for www https:// connections .

? port 22? I don’t know what duckdns tells you to do, I don’t use anything on duckdns

when you set up ssh on, you configured a ssh key. ssh keys have nothing to do with https certificates

I have no idea what VPN you are referring to. Perhaps more details would be beneficial.

It is really a simple concept. You have ssh keys that you configured. You need those to access the SSH service. There is nothing inherently in that prevents connecting over ssh from the outside. This is merely a configuration issue on your network and a lack of ssh keys on your client device.

i think i understand…

still, on my home network i can ssh root in with my iPhone…
my other client, Macbook, is likewise.

VPN is on the client side, both on mac and iPhone i run either PIA, or Tunnelbear.
I’ve got the keys in my /ssl folder

so start with some basic troubleshooting.

you can ssh in on LAN from iphone and mac

when you disconnect from your wifi, and you try your external IP, are you getting any response? (Don’t use any VPN for this test)

You have verified that you have some external port forwarded to your IP port 22 right?

that’s it!
Missed that before… :confused:

Yeah, when you are dealing with your home network, and trying to access it remotely, it is typically an issue with the port forwards. :wink: