Remote UI stopped working

Hey there,

recently a notification showed up on my Home Assistant Core Installation:

Home Assistant Cloud

Unable to create a certificate. We will automatically retry it and notify you when it's available.

I checked in the settings and remote UI (Fernsteuerung) was turned off. When I try to turn it on I get the following:

The certificate has expired and for whatever reason has not renewed itself. Im using DuckDNS+Let’s encrypt and that is still working fine. Nothing has changed and it had been working perfectly for months. Any ideas?

In my logs I also find this:

Can’t order a new ACME challenge: urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Account is not valid, has status “deactivated”

My account is active though.

Tried relogging, I can’t log in again - I get the following error:

2020-02-22 13:27:35 ERROR (MainThread) [] Unexpected error processing request for /api/cloud/login
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 129, in error_handler
    result = await handler(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/components/http/", line 50, in wrapper
    result = await method(view, request, *args, **kwargs)
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 196, in post
    await cloud.login(data["email"], data["password"])
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 179, in login
    await self.start()
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 237, in start
    await self.client.logged_in()
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 120, in logged_in
  File "/usr/src/homeassistant/homeassistant/components/google_assistant/", line 210, in async_enable_local_sdk
    self.hass, DOMAIN, "Local Support", webhook_id, self._handle_local_webhook,
  File "/usr/src/homeassistant/homeassistant/components/webhook/", line 33, in async_register
    raise ValueError("Handler is already defined!")
ValueError: Handler is already defined!

After refreshing the page though I appear to be logged in. It says it’s setting up remote UI but the status never changes. I found another error in the logs:

2020-02-21 14:11:54 ERROR (MainThread) [] Unexpected error processing request for cloud/remote/connect
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 148, in error_handler
    return await handler(hass, connection, msg)
  File "/usr/src/homeassistant/homeassistant/components/cloud/", line 452, in websocket_remote_connect
    await cloud.remote.connect()
  File "/usr/local/lib/python3.7/site-packages/hass_nabucasa/", line 250, in connect
    raise RemoteNotConnected()

Have you fully rebooted the device which is getting the “handler is already defined” error?

Yeah, does not help unfortunately.

Deleting the .cloud folder in the config folder and rebooting did the trick.

Hi I am having the same issue here. I deleted the hidden cloud folder in the config and rebooted but still the same issue. It started when I restored my build from a backup using an older build version (having stability issues with the latest release).

I assume you haven’t had any further issues with this?

No, I had not. But you can try this: Sign out from the cloud, then delete the folder, restart Home Assistant, then reconnect/sign in again. I don’t know if you had signed out at al/had to reconnect after deleting the folder, but I am pretty sure that I was signed out prior to deleting the folder.

I just left it for a while and it seems to have come back. Took about 20 minutes. I can get on with my day now. I wish I could just leave this damned thing alone as I am always tinkering and improving!