Removal of GPIO support

Can someone tell me if any of the viable GPIO replacement options (HACS and mqtt-io) support input on the Raspberry Pi 4b with a 64-bit kernel? The inputs have never worked for me with 64-bit kernels, which as forced me to use a 32-bit kernel even on my 8GB RPi 4b (which is a waste). Are there other options I should be considering?

ESP isn’t an option for me, unfortunately, as I have a custom board built around the RPi connector and I need a UPS to guarantee that the GPIO works so don’t want to put any more load on the UPS.

Hi Porch,

any hints, how I can put MQTT IO on the same PI as my HA?

I’m already using Zigbee2MQTT, which is available as an Add-On in HA and hence was easy to install.


Hi, in my case it does not works …

My configuration:
Operation system: Home Assistant OS 7.6
supervisor: 2022.04.0
core: 2022.4.6
Python: 3.9.9
Raspberry Pi4

I coppyed whol directories “mcp23017”, “bme280” and “dht”, from relese 2022.3.8, and put to \config\custom_components, with that result:
-Platform error switch.mcp23017 - Integration ‘mcp23017’ not found.
-Platform error sensor.dht - Integration ‘dht’ not found.
-Integration error: bme280 - Integration ‘bme280’ not found.

What I did wrong? please help, at the moment I have to switch back to march version of the core …

You have to restart Home Assistant after you add a custom integration before you can use it in your config.
You’ll also need to add a version to the integration’s manifest.json if you have just copied it from the core.

First of all, thanks for quick reply, it should looks lik this (example for mcp23017 manifest.json)?:

“domain”: “mcp23017”,
“name”: “MCP23017 I/O Expander”,
“documentation”: “Removed integration - Home Assistant”,
“requirements”: [
“version”: “2.2.2”,
“codeowners”: ["@jardiamj"],
“iot_class”: “local_polling”,
“loggers”: [“adafruit_mcp230xx”]

Yes, I think that should work.
Please use the proper formatting the next time you post json, yaml or code in general.
Among other things, it should prevent accidentally tagging people like you just did in your previous post.

It works!!! :smiley: - thank you very very much @ondras12345
And sory for my previos incorrectly formated post

I did a quick port of the existing onewire component so people can continue to use sysbus with onewire.
just add the following to HACS:

I made a custom integration based on the latest core code for Raspberry Pi GPIO component. It is still very raw, so there is really no documentation yet - it will be a little later. Installation is currently only available manually. You can test…

This would be the second port of the original core rpi_gpio integration I’ve seen.

No doubt when the day comes that I need to update it, I’ll have forgotten which one I used and where I got it.

Are there any plans to make an “official” add-on that will be available from the UI?

What exactly is the advantage of your fork over to the first fork from thecode that is available on default HACS ?

Unless they add something substancially new, everybody starting their own little GPIO integration forks is going to be counterproductive, because it’s really confusing for everybody.

I agree, that fork is better. At the time of the creation of my fork, I did not find it, because for some reason it was not in my HACS database. I made mine for myself and just shared with everyone. Well, let it be the one, since there is already a good job done there …

Hi all

I think much of the discussion could have been prevented if the depreciation information (Removed integration - Home Assistant) would mention the possible solution’s proposed in this 140 messages:

  • use remote gpio integration (which will not be depreciated)
  • use mqtt to communicate with gpio
  • copy old code to custom folder
  • install from repository mentioned above using hacs
  • use esp32 (not doing 100% the same but for future usecases an idea to consider)

Did I miss anything?

Can anybody add the hints there?

Here is the description (I tried to log in to GitHub and add it myself but didn’t find the right file as the depreciated page is linked to a default information page.):

Proposed solutions include:



Updated HA to 2022.6 on my RPI yesterday and was “surprised” to see that rpi_gpio and 1-wire support was removed.
I use HA to control power from solar panels and a heat pump using relays and ds1820.
rpi_gpio was easy to reinstall via HACS. But 1-wire still don’t work. owfs / owserver apparently don’t work with the 1-wire interface on rpi - or is there a guide that I dont know?
What is the simplest way to get HA on RPI to read 1wire data in /sys ?
Br Jorgen

PS. found this on github - will try it out during this week:

1 Like

@jorgen_DK if you are already using OWFS / OWserver, one option would be installing a I2C to 1Wire board such as this one

Yesterday I installed ha-onewire-sysbus on my HA on RPI - it simply works.

After the rpi_gpio support was removed from HA. Has anyone been able to get a DHT22 to work on a HA Supr RPI GPIO Pins?

So I bit the bullet, got a d1 mini, a few jumper wires, a micro usb power adapter, a 10k resistance and a prototype board.
Got my four ds18b20 back online today and I’m back to monitoring ac and gas furnace performance.
It’s not the prettiest thing and probably will need to get a case but it works

After update core to 2022.7, the custom components stopped works :frowning: again, do you have any additionall tips, to be able to use DHT22, BME280 and mcp23017 components?

Here is the solution to RPI GPIO problem.