Remove .homekit.state


I am new to all of this. Bought a RaspberryPi 3B+. Installed the image file on an SD card and got going. This is working ok. But there are a lot of things that I do not know how to do and I need help. Again, I am a complete beginner so I need super simple instruction (thanks).

I can reach Home Assistant from my Mac or directly from the RaspberryPi. When connected to the RaspberryPi I am asked to login on HassOS. I have no alternative to doing that.

I have HA version 0.75.3.

  1. I tried to setup HomeKit with HomeKit: and it worked so far as that I received a code and could enter it into the Home app. The code was accepted but the bridge was never added (the wheel kept spinning). It says that I should remove .homekit.state. I do not know how to do that.
  2. It says that I might have to download a package with the following command:
    $ sudo apt-get install libavahi-compat-libdnssd-dev
    I do not know where to enter the command.

I would really appreciate hela with this!

Beginner here as well. Did you solve you HomeKit problem?


Yes. I deleted the file called homekit.state. which I found n the config library. Then I restarted and got a new Homekit code. This time it worked. I did not need to download anything.

Same issue here. I’ve deleted the file but no code after restart.

The docs suggest that there is a 100 device limit on HomeKit which is probably why it failed to integrate first time. I’ve excluded all sensors, automations and scripts.

Is there anything else I can try to get the code again?