Remove only DHCP Discovery

What needs to go back into the configuration.yaml to disable ONLY dhcp discovery. I tried to simply leave the default but add dhcp:disable and this failed. So currently, I have the default config disabled, but obviously lost other things in the process.

Ultimately, this DHCP item has been a gremlin in my home network as devices keep going offline due to the dual dhcp servers (well 3 since I have 2 home assistants). This is a HUGE issue, so I want to make sure it never comes back.


As far as I know the only option is to remove default_config and add what you need from default_config separately.
Here are all the parts included in default_config. Add what you need, but leave out dhcp.

I wish they would write it in the release notes when they add something to default_config.

1 Like

What do you mean with “you”? Did you mean “they”? I’m not involved at all in the development of HA.

I stopped using default_config a long time ago and just add the individual parts as I don’t need most of the things that are included there.

Sorry, I meant ‘they’

Correct me if I’m wrong but doesn’t this simply listen for the dhcp requests?? It’s not actually serving IP addresses so I’m not sure that this would be the cause of your issues.

1 Like

This was my impression as well; it simply listens for DHCP requests and uses that as the basis for discovering devices. It doesn’t act as a DHCP server (i.e. it doesn’t issue an IP address when it detects a DHCP request).

Well, with it listening, the tasmoto devices I have seem to go online and offline constantly. My network is a Cisco managed 48 port gigabit switch with a unifi security gateway and asus mesh wireless acting as APs only. The mesh is hardwired. I thought it was the mesh’s fault, but as soon as I disabled the DHCP, everything played nice. So I am not sure what to tell you, other than it was creating havoc.

I don’t dispute your observations. However your experience implies many other users should be reporting stability issues, because the use-case is quite common, but it hasn’t been identified as a widespread problem. Perhaps you are the first to notice it.

I was searching for a solution for my network problem when I stumbled on this thread. I am also having the same problem. At random moments my network devices lose connection to the network and after disconnecting the raspberry pi with home assistant all devices reconnect again. After I connect the raspberry pi again all works fine until this happens again. Disabling DHCP discovery solves my problem also.

I have this exact problem and really dont know how to fix, I dont have default_config enabled in my config and dont have dhcp: enabled, is there some way to test, but like @Qanqan said its sorted as soon as I unplug the ethernet cable from the Raspberry Pi, i’ll try to disable discovery: incase that helps as well, really weird issue!