Remove scene actions from Apple Watch


How do I remove scene actions from Apple Watch? I remove them from the ‘Actions’ area however they reappear.

This white tiles circled here are what I am referring too.


I remove them from here within the HA app and they reappear.

@tux43 did you figure this out yet? I just noticed it on my Apple Watch. Incredibly annoying!

@_Mike No, unfortunately. It is pretty ugly however have learnt to put up with it. Hopefully, one day it will be fixed.

1 Like

I actually have never used HA scenes. I create all of mine as scripts. They function basically the same way, but you have a little more control within a script. But for me, literally hundreds of scenes appeared on my watch this week. I finally realized it was due to the changes in the Hue integration - HA automatically pulled in a ton of unwanted and unneeded Hue scenes. I have disabled them all. Hopefully that keeps them out of my watch!

This is still a problem after almost 3 freakin’ years!

Yup. I keep checking every couple of months to see if a solution has happened yet.

Go to Home Assistant - Automations & Scenes - they should appear under scenes. Delete theme from there.

Worked for me