Removing old entities

I have some old entities that I can’t get rid of. I’m not sure if it’s an error in an integration, or something in HA itself, so thought maybe someone can help.

It’s basically the problem in this topic. Somehow I ended up with double all the entities of the integration, and I can’t find out how to get rid of them.

Any help would be appreciated!

See the screenshot for the entities I mean:

Did you try to go to the entities page under settings and remove them there?

You might need to remove the integration, remove all the entities and then add the integration again. But, one of the two sets of entities (probably those without the 2 suffix) you should be able to remove and then you just rename the newer ones.

I tried removing the integration, then all the entities, and then re-installing. Unfortunately they all came back. :frowning:

Have you tried checking the open issues of said integration?

Yup, nothing in there, also not in the closed issues. I can add an issue of course, but I wouldn’t know where to start to give all the info needed to add a proper issue, other than the data I provided above. I might try adding it after all and see what the maintainer(s) say.

I have the same issue… treid to remove them from core.entity_registry as well but they just cam back… the entities come from Modbus integration after playing arround with the sensors comming from Modbus… It is a pain now to select the right entity due to the longnames and the _2 added at the end…

For either of you: How are your integrations connecting to HA? Via MQTT?

Standard Modbus integration from HA

I have the same issue. Added some modbus sensors to my configuration.yaml and played with them, incl. renaming. I also commented some of out again since I will not use them. However, all of them are still showing up in the overview, including renamed ones, with their “old” and “new” names.

In the “Entities” list, they show up as “Read-only”, so I cannot delete them there.

They are neither listed in core.device_registry nor core.entity_registry and my HA installation is still very vanilla as I just started to play with it and have absolutely no automations etc. yet.

clear browser cache or use incognito

2 Likes

Same here,
I have a lot _2 entities which I can not remove. At the same time the original sensor went dead. Nice deadlock.

I created an issue here:

and there:

not too much attention unfortunately. It must have done something to do with the 2023-11 update.

Almost all my energy sensors are dead now.

what a bummer.

Why is every ignoring @totolino reply ? (Removing old entities - #10 by totolino) its spot on and fixes it.

Didn’t remove the entity for me in HA 11.5.