Removing old helpers

Same here. There is still no option to delete or edit helpers in my case.

yup, thank you very much!

Thank you. That worked. I appreciate it.

In my case, I created a dropdown helper. Then I wanted to edit the dropdown choices, but the gear icon just showed a box with helper title. After rebooting HA, the gear box gave me the full interface and I could edit the helper. Core - 2023.12.3
Supervisor - 2023.12.0, Operating System - 11.2, Frontend - 20231208.2

I have a Helper that has no Entity ID. Without an entity ID you can’t delete the Helper. Is this a bug or a feature? I’m doing a bit of year end clean up and working my way thru the systems logs and try to clear a few entity error messages.

Thanks,

I’m having this issue with a handful of helpers. They are group helpers. I read on some other thread that there’s a problem when it doesn’t have a unique ID. This may be the case because I accidentally named it the same as a Philips Hue room when I was trying to decide which method to use to group the lights. Philips Hue creates its own groups but I was attempting to create a group on my own within home assistant. Now I have a group that is a home assistant group helper It has the red blob and cannot be deleted. It doesn’t show up in configuration and it doesn’t show up in the entities. Anyone with any ideas?

Edit:
I was able to go into the entities page and at the top select the filter to turn on all four check boxes that appear under the entities tab that shows disabled entities. When I did that, they showed within the list and I was able to click on them, then get the pop up with the gear icon, then get the delete button. Shew!

1 Like

I came here to say, I was also having problems deleting helpers. Going over this forum post, I thought I was going insane because the delete button was not there.

Then I realized my ad blocker/js blocker was enabled. Disabled for my HA instance, and now my settings gear shows data, including delete!

4 Likes

Would never have thought to try this, thank you!

Been fighting this for a while, kevinmckeown solution worked perfectly, Thanks.

That’s the solution!!! In my web browser, I was not able to delete a helper. The app did it no ad blocker there…).

Thanks a lot!

Future people search to resolve:

Mine was an issue with Chrome, I could only delete via Opera for input Boolean type helpers, some helpers I could delete but certain types of helpers had no delete button via chrome.

Also had an issue with this. And yeap, it was because of browser. Refreshed cache of page (Ctrl+F5) and it fixed.

Same Issue with the “hidden” delete button.

After some thread reading, I tried to open HA with Chrome instead Firefox as I do usually:

¡¡¡It worked!! the delete button showed up.
Thank you all

1 Like

Worked perfectly, thanks! Don’t need to resort to editing the core files.

Same issue for me, the Settings pane in the helper had no info or delete button in Edge browser.
I switched to Firefox and there it was.