Removing old helpers

Hope I’m in the right category. Migrating automations from Node-RED and have a bunch of old inputs (booleans, selects etc) from my configuration file. I have deleted them from the file, but they’re still showing in the list. Anyone knows where I can delete them completely?

Thanks
/k

If you mean in the History list then they will vanish automatically once the period of use is over.
So they show today but will be gone tomorrow.

No, I’m talking about the list where I can create my own helpers. I have deleted them all from my configuration file, but they still show up in the list.

I’m sure you’ve figured this out by now, but here’s what I did just to help anyone else searching for an answer. Open the “core.entity_registry” file in the config/.storage folder and search for each item you want to delete, such as input_select.lock_zwave_option_3_front from my example below. Then delete that entire section (everything I have highlighted) being VERY careful to include the opening “{” and the closing “},” If it’s the last section in the file then you need to delete the comma from the section before it. Then restart HA for the changes to take effect. I would create a backup stored off of your device before performing the deletions.

image

4 Likes

this does not work. It get’s replaced every time i restart… is there an other solution?

I have an input_select helper configured via yaml that I am not able to delete after renaming them. What makes matter worst is that the new renamed input select goes unavailable too after restart and I can usually bring it back up after input select reload before 2021.4.
I have tried removing it from yaml and recreating via helpers UI but still unavailable. GREP of the name shows nothing on .storage. I don’t see any entries of entity on the mariadb I’ve been using except on the restore states.
I’m trying to figure out which component should I put on debug mode.so I can finally fix this.

Time passed… as of Home Assistant 2021.12.6, on Helpers page, clicking on the Entity ID now shows a Delete option.
Similarly if it’s showing on Lovelace but no longer needed, click on the unneeded Helper Entity ID, then Entity Settings (top right) to get to the same Delete option.

4 Likes

worked for me, but you need to have removed YAML and helpers prior, otherwise the entity will just keep getting created.

I am using Home Assistant Core 2022.6.5 and cannot find this option. Does anyone know where it has moved?

1 Like

Settings → Devices & Services → Helpers → your helper → delete


3 Likes

Just to clarify: you need to click exactly on the helper name or Entity ID – not just the right row. This is pretty weird UI design. One would expect clicking the row acts like a huge button for pressing the name/id.

4 Likes

As of August 8, 2023 (Version 2023.8) Here you are:

Helper - Removal

1 Click on “Settings” in the left-hand frame.

  1. click on “Devices and Services”.

  2. at the top, click on “Entries”

4 Click on the entry you wish to delete.

5 At the top of the window that opens, click on the jagged wheel.

  1. at the bottom, click on “Delete”.

Hope it help :slight_smile:

On 2023.8.4 (possibly earlier, I can’t say for sure), the settings dialog for helpers seems to be broken. When I click on the gear icon for a helper, I get a blank page. I can’t rename the helper, can’t change the icon, and can’t delete it.

2 Likes

Same here.



Clicking gear icon:
image
The card is blank. This is just for toggles. Groups or numbers works as expected.

Edit: Restart HA and refresh page. Then the page appeared.

Same need to try in browser. But I get that in the app too

How to remove a Riemann helper for a non-existent entity? When i click on such a helper, I can only set the precision value. There is no delete button.

As of 2023.10.5 (it’s still quirky!):

  1. Settings
  2. Devices & Services
  3. Helpers (across the top in Integrations / Devices / Entities / Helpers) - make a note of any with a red blob
  4. Entities (across the top in Integrations / Devices / Entities / Helpers):
    (a) xxx entities not shown - click CLEAR
    (b) find the entry for those Helpers, click on the entity name
    (c) Cog wheel (top right of the pop up)
    (d) Delete (bottom left)
4 Likes

This is still an issue.
I added a button helper, noticed the typo too late, failed to fix it.

None of the tricks here worked and so far I haven’t been able to come up with anything else.

All I get when I hit the cog is an empty card.

Extremely annoying. Perfect WTH moment.

I’m not eager to dig around in HA’s innards in order to get this done, but I need this helper gone.

This is the correct way. The issue seems to be that the helper identity is set to disabled, which in turn doesn’t show the delete button on the helper page.

Deleting it straight trough the entity solves this issue.

It didn’t work in my case.

At some point I was able to delete that dogged helper, though, and I didn’t know why.

So I’ve tried to replicate the issue and it seems to be a browser cache problem:

Turns out I can always delete them after fully reloading the page (Ctrl F5).

1 Like