Removing unwanted entities added by Ariela app?


Apologies if this is answered somewhere in a thread already (which I was sure it would be but couldn’t find one) I did look.
I’ve been experimenting with the app and how best to use it. As a result, I have a number of Entities instigated by the app in my Hassio instance which I would like to remove, but don’t seem able to do it from the app (disabling the sensor in question) or from Home Assistant it’s self (cant find the config listed anywhere)
Have also tried deleting the mobile_app integration with no luck.

Can someone kindly point me in the right direction?


EVERYTHING is accessible via the configuration tab in Home Assistant.

If you have ENTITIES that exist that you want to remove, you delete them from the ENTITY REGISTRY

Thanks for taking the time to reply.

I wish it was easy as that…
I can find the entities listed in Developer Tools - States - Entities (sensor.galaxy_s9nbsgalaxy_s9nbs_battery_sensor) for example.
Definitely not listed in the Entities Registry in the Configuration tab, I’ve checked numerous times!


Have you tried the DEVICES section in configuration?

Yes, I have.

Trying to delete a device advises you to delete the Mobile_app integration and restart HA, which then leaves the Entities in place after restart…

You might have found a bug then. Shut down Home Assistant and CAREFULLY (after making a backup of the file) edit core.entity_registry or mobile_app files located in the .storage directory. If you screw up the JSON, your system will not load.


Ahead of you on that, none are listed in any of the files located in .storage…
mobile_app doesn’t exist at all…
Thanks for your time on this.


All of the sensors created through Ariela are in a file called mobile_app in the .storage directory on my system.

They are not named the same as sensor.<device>
The named used in HA is pulled from the “type” in that file.

Problem is mobile_app doesn’t seems to exist on my system. Definitely not in .storage and nowhere else from what I can tell…

Mobile_app is just a component which should be automatically loaded. If not just add mobile_app: to your configuration.yaml, restart HA and check if works.

I’ve worked it out.
The sensors in the app were enabled using MQTT.
I did a completely clean install of hassio with a restore from a couple of weeks ago so I was sure there was no Ariela integration at that point with my instance of HA.
Low and behold, the sensors appeared! This lead me to believe I was either going mad, or the config was being persisted elsewhere which lead me to checking the logs of my MQTT server.
Removing the .db file for my MQTT server solved the problem.

This is not a very elegant solution and is essentially a bug in the App implementation that someone might want to look at fixing…

You didn’t need to remove the MQTT database. You could have just sent an appropriate message over MQTT for the topics they were tied to.

Actually, I don’t know if the app could have any control over that. Unless it sent an empty message to clear the topic it was listening on.

While I understand your frustration with it, you’ve discovered a flaw (bug) in a piece of software that someone writes in their spare time…please be mindful of that.

1 Like

Hi @flamingm0e

Thanks for your reply.

What is the appropriate message/s?

I have no problem with that, and understand entirely.



If it’s like the other auto discovered MQTT devices you send an empty payload.