Rename friendly name for HASS vanished from Z2M add-on

Hi, I’ve been tinkering around with Z2M, and I think I’ve got the config etc back to a proper state, yet the ability to rename device names from inside of Z2M has vanished. Screenshot below

I noticed same last night.

Known bug. Fixed in next release. If you need it right now you can move to the dev / edge branch, it’s fixed there already. Where is the rename button? - #9 by fleskefjes

Same issue. I went to the device’s settings tab, at the very bottom is the Home Assistant name to update. However, it didn’t update Home Assistant to that name; even after a restart of everything. I had to manually change the eight entities to the friendly name. It’s annoying for one device but if I were adding multiple devices at the same time, it would spin me into a fit of rage.

when it was introduced ? I’m asking because this has to be very recent (past 5 days).
Dunno if you’ve seen my screenshot - the option for hass is missing, not the ability to rename.
When the release will happen ?!

1.37.0. The release will come when it’s ready, if you have no time to wait just install the edge branch.

1 Like

Yeah, I’m about re-add 167 devices to zigbee network due to change of coordinator - that kinda makes it “suboptimal”

I’ll hold off then, but I would like to mark in the calendar when I need to schedule a major mesh rework.

No one is asking you to re-add anything. Just wait or install edge, takes you literally 20 seconds.

1 Like

I think you got me wrong, “I need” - caused by other circumstances change of coordinator (and channel) - “re-add 167” - remove from one coordinator and add to another.
I’m not implying that z2m pushed me into that.

Gotcha. Anyway, if you want to do this now just stop regular Z2M, install Z2M Edge, do your thing and then stop Z2M edge and start Z2M.

hmmm, so in spirit of “before I’ll get my self into more trouble that I’m in” - if I install “edge” will it show up in place of normal, or as a separate addon → item in side panel ? I assume I’ll need to point it to the same config / clone existing config ?

Weeeelllll I’ve followed your advice on using Edge, and DNFW ;(
I’ve tried renaming the device, however following is the result that I get:

This is device name in Z2M edge after changing name and ticking “change HASS name”

However, I’ve even tried changing name through device settings tab → hass name

and this is how device is percieved in HASS

Am I missing something ?

Just as a side note, I was going through the mqtt settings - it’s using 3.1.1, shall I bump it to 5 ? (asking since this hass been rolling for over two years and maybe this setting is stalled).

I did the same as you describe, and that worked perfectly here.

Well, I found a bug, or at least “logical bug”:

  • IF you had already renamed the device in z2m several times and then try to rename it in edge with “rename hass” ticked - z2m seems to not do that, at least it will not do it for me
  • IF you rename the device in mqtt, z2m will not attempt to rename it (with rename in hass ticked), again at least for me.

Both of the devices I had to bet removed from the network → pair → rename works OK.

Of course we can qualify it under “it’s a feature not a bug”, but my punny mind works in slightly different way :slight_smile:
Anyway, thanks for your help & advice, at least now I can start shifting things to a new coordinator.

1 Like