Renpho Smart Essential Oil Diffuser

Hey friends,

I bought one of these on Amazon a few months ago on special for $25.

Today I got around to pulling it open, with the intention of seeing if I could easily flash it with tasmota or similar.

I noticed right away it was a Tuya based ESP8266 inside, so I tried reconnecting it to my wifi using the Tuya app, and it worked!

So its a Tuya device, and shows up in the Tuya app as a Essential Oil Diffuser, with two controls. It has the light control, RGB, and ‘Mist’ control, which is either OFF, LOW or HIGH. Theres also timers for mist but I dont need that.

Essentially, its an RGB light and a fan.

I was hoping that it would just show up in Home Assistant after adding it to the Tuya app, as I already have a Tuya light bulb that I use and is working fine, however no new entities have appeared after adding to Tuya and restarting / forcing updates :frowning:

Does anybody have any insight as to if this should work or if theres anything I can do to get it going?

Thanks !

A friend of mine has the same problem with his new cool mist humidifier.
It just doesn’t show up in any of the apps. And we can’t find the solution. We hoped this topic would have an answer…
P.S. For yours it is recommended on Amazon RENPHO SMART app.

yeah its own app works, but I want to have it in HOme Assistant… theres a Tuya UART component for tasmota or something that might work now, but I havent given it a try

Any luck guys? I have the same problem… added the tuya component but no devices were found. I’m using the tuya Smart Life app.

1 Like

I have the same problem

The newer version of Tasmota work great on oil diffusers. I never got mqtt autodetect working so I decided to switch the firmware to ESPHome instead.

hey i know its been a while, but would you care to share the config for esphome?

I have a merkury diifuser and i cant get everything working right in tasmota, and all my other stuff is on esphome anyway. Just want to make sure im headed in the right direction with the config.


Hey guys.
I have same diffuser and want to use tasmota. But I’m still fighting with config and I’m not able to set it properly. Only thing what I was able to control is wifi led light :confused:
Somebody who can help me? Thanks