Reolink 823A Ffmpeg not working with Frigate

Hi all,

I am struggling to get any video feed with Frigate on Home Assistant on a raspberry pi 4. Here is my config file:

  host: 192.168.xx.xx
  port: 1883
  user: frigate
  password: password
        - path: rtsp://admin:[email protected]:554/h264Preview_01_sub
            - detect
            - record

log file from Frigate

023-11-25 21:17:24.553616049  [2023-11-25 14:17:24] watchdog.soffit                ERROR   : Ffmpeg process crashed unexpectedly for soffit.
2023-11-25 21:17:24.554765887  [2023-11-25 14:17:24] watchdog.soffit                ERROR   : The following ffmpeg logs include the last 100 lines prior to exit.
2023-11-25 21:17:24.562120726  [INFO] Service NGINX exited with code 256 (by signal 7)
2023-11-25 21:17:25.135709326  [2023-11-25 14:17:25]                  ERROR   : soffit: Unable to read frames from ffmpeg process.
2023-11-25 21:17:25.137068366  [2023-11-25 14:17:25]                  ERROR   : soffit: ffmpeg process is not running. exiting capture thread...

I tried making the config file as small as possible. I’m pretty sure the mqtt is working because if I intentionally have the wrong password I get an MQTT error. I also tried accessing the main and sub rtsp streams on the VLC viewer on my Win11 PC and those worked fine. (h265 for main, h264 for sub). I can also ping the camera from the console of my home assistant.

I tried the config file recommended for Reolink on the Frigate docs, but that gave me the same error.

The camera works fine with my reolink app. I also had it running with the Onvif integration until I intentionally disabled that in case it was causing issues with Frigate.

Thanks for the help!

Hi. I have the same problem. Were you able to resolve it and if yes, could you post what you did to solve it?