Reolink E1 Pro indoor and HA/Frigate

I spent a week trying to get my ReoLink E1 Pro into HA. I want to use it with Frigate. I found an instruction to load go2rtc and put the cameras in there, then bring them into Frigate.
What I discovered:

  1. By default, rtsp and onvif are turned OFF. Not knowing this, I tried 100s of different urls which never were going to connect. I could not find where to enable this in the phone app so downloaded the reolink app to my Mac. In there, go to the camera > settings > Network > advanced > server settings and there are the check boxes. tick rtsp which then allows the tick on onvif. Click save.
  2. I also went into the camera > system > user management and made a different admin account to use to connect HA to my cameras. I went with Admin4 but will probably change it to something more random and longer. Long Random username and long random password makes brute force guessing a little harder.
  3. Now that rtsp/onvif are enabled, my instructions to use Frigate in HA included loading go2rtc. In the config for go2rtc, I name the camera and I put in this line onvif://Admin4:[email protected]:8000?subtype=001 with your actual name/password/IP address. subtype 0 is low res stream, 1 is hires stream.
  4. next telling frigate the name of the cameras in go2rtc and setting up their configurations.

Another troubleshooting hint for us noobs is learning that spaces mean something in Yaml so making a config and branching the settings with spaces (not tabs) makes things work better.

Another bug I found in reolink on the macOS is when the IP address changes, restart the app. I change the IP during setup and once I have it right, it won’t matter when in production as it won’t change.
I was also successful in blocking the camera from the internet in my router while still feeding my phone (local ip only) and HA server (also local ip) and setting my router to be a NTP server. To change the NTP, go into each camera > settings > network > advanced > NTP settings and pick “other” in the drop down. I put in my router IP address and now it gets the updated time. Blocking the internet also means manual firmware updates but these new cameras out of the box did not detect a new firmware online when there really was one (1/10/2024) do downloaded it from reolink and applied.