Reolink Failed to setup - Multiple Unknown Log Entires

I have a somewhat odd problem with my Reolink. I set it up months ago and in the beginning, it worked great, then things stopped working after an HA update, I tried a bunch of things and of some reason, it seemed to line the NVR was struggling (Overloaded), back then I ended up “hiding” a bunch of entities as I was really only using person detection and siren on/off and somewhere along the way it then worked again. Now it’s been working for about a month with almost no log entries and no problem, but then we had a power outage and everything is back to shit. The outage was 2 days ago and I am still struggling to figure out what is going on. There are multiple log entries, sometimes it works, sometimes not, sometimes it was initialized and sometimes it can. I am about to give up as I have tried everything that makes sense to me.


  • Core2024.2.5
  • Supervisor2024.02.1
  • Operating System12.0
  • Frontend20240207.1

Native Reolink integration - Reolink IP NVR/camera - Home Assistant

Cameras: RCL1224 A (LAN) and RLC-810 WA (WIFI)

Logs on HA (Multiple)

Logger: homeassistant.config_entries
Logger: homeassistant.components.automation.alarm_state_disarm
Logger: reolink_aio.api

Logs on NVR

Looking at the logs on the NVR I see that HA keeps logging in and out several times a minute, sometimes 3 times per sec.

I wish I knew what I should upload for this to make sense - I just didn’t wanna upload 250 pages of logs of all sorts, kinda hoping someone recognizes this and has a solution.

If this were me…

  1. Make sure the NVR IP address is static, the Ethernet cables are good, the Ethernet switch is good, and there is no network loop or problems.
  2. Install all Reolink firmware updates on the NVR and Cameras. Make sure the NVR is happy after that from a PC or app. You have to do this manually, using the GUI from inside the Reolink NVR frontend to check for updates does not work (for me, anyway). Check the Reolink websites and make sure the latest available is what you are running. Reboot HA host.

See if that has fixed it. If not

  1. Completely remove Reolink is from HA, Restart HA, make sure by searching there is no residue of Reolink in there.
  2. Wait a few hours, reboot the HA host and check again for anything Reolink remaining.
  3. Re-install the integration by the book.

So, I guess no one experienced this before, so I chose to start over with Reolink. Removed the integration, added the integration and this time set up a user called HA and not admin.

After an hour I noticed that the Reolink log was calm (Before I would see 2-8 log in / log out per second.

Now I am seeing one log in and one log out 45-60 minutes and I guess that is acceptable.

So it’s stable now, but with past experience I wonder how long.

I also would love to know why the HA is logging in and logging out all the time?