Reolink Setup "Config flow could not be loaded: 500: Internal Server Error"

Yesterday I added a Reolink RLC-810A to my mix of cameras and was very happy to find the HACS Reolink Discovery integration and the associated Home Assistant Reolink IP NVR/camera integration.

My original installation failed but was corrected when I added an external_url entry to my configuration.yaml file:

external_url: "https://{MYname}{PortNum}"

Today, I attempted to review the prior day’s work.
When I click CONFIGURE on the Reolink Device Discovery I get the following message


I enabled debug logging:


…and tried again, same error message, but I don’t see anything in the system log (should I be looking elsewhere?)

I tried HA-Restart and HA-Reboot. (Enabling debug logging each time). I always got the same result.

Access to the camera works AOK.
Should I be concerned about this? Ignore it for now?
Await the April update? (it looks to be impressive).

Thank you for any insights. :wink:

5 days later I have not been able to resolve the “Config flow” error message. (uninstall/reinstall, install current system updates…)

I’m not sure, but I think this problem is creating other downstream issues.

Motion/Person/Pet/Vehicle events are NOT reliably passed from the camera to Home Assistant.
With the Reolink app open, I can walk in front of the camera and see the smart motion detection icons appear on the camera view. Simultaneously, I can display Developer Tools → States:

and observe that the related Home Assistant binary sensors do NOT change from OFF to ON. (more accurately, they change from OFF to ON about 20% of the time.

I have a similar setup working on Amcrest cameras, but I have been unsuccessful with Reolink.

@starkillerOG: I realize this is likely a user error, but wanted to ask if there are any known issues with event posting? Any insight provided would be much appreciated. Thanks!

System information
Version core-2023.3.5
Installation Type Home Assistant OS

Home Assistant Community Store
Installed Version 1.31.0

Home Assistant Supervisor
Host Operating System Home Assistant OS 9.5
Update Channel stable
Supervisor Version supervisor-2023.03.2

Alright. I have given the Reolink IP NVR/camera - Home Assistant ( another read, I see that:

These sensors are polled every 60 seconds and receive ONVIF push events for immediate updates. Not all camera models generate ONVIF push events for all event types, some binary sensors might, therefore, only be polled. For list of Reolink products that support ONVIF see the Reolink Support Site.

Furthermore, looking at the camera settings, I see that the shortest push interval allowed is 20 seconds:


I don’t know if this is correct, but this tells me that an object can be “in view” for 19.99 seconds without generating any sort of alert.

I scrapped my intermitently useful H-A automation and replaced it with a “polling” Node Red automation. So far Node Red seems to do the job as intended (at the cost of sytem-side polling overhead). More testing to follow.

@YetAnotherDave you could very well be experiancing the same issue as described here: Reolink RLC-520A V2 not triggering AI sensors · Issue #89773 · home-assistant/core · GitHub
The fix has been implemented in this PR: Shield Reolink webhook callback from cancelation by starkillerOG · Pull Request #89798 · home-assistant/core · GitHub and will become available in HomeAssistant 2023.4 that will be released on April 5th.
If you want you can already try it out comming wednesday with the beta release version.

Please first test with HA 2023.4 and if it still does not work, please let me know by making a issue on the HomeAssistant core github.

1 Like

Just seeing you are using a custom integration for reolink. Please remove all custom reolink integrations (from HACS) and try out the build-in official Reolink HomeAssistant integration.

1 Like

I removed, in order:

  1. Reolink Integration
  2. Reolink Discovery
  3. HACS Reolink Discovery

Followed by:

  1. reboot
  2. reinstall Reolink integration

Standing by for the HA 2023.4 build. Thanks!!

This sounds exactly like the problem I have encountered. Today when I drove out of my driveway (past my RLC-810A) a “Vehicle turned on” notification appeared in the Home Assistant Logbook. When I returned no such Logbook entry appeared. However, both video events were recorded on the camera’s microSD card.

Thank you!


I was not having success with Push Notifications from the Reolink App. I thought that might be an underlying problem. It is NOT.
The fix: UID must be enabled for Push Notifications to work. At least on an RLC-810A with this firmware:


see: Reddit - Dive into anything

The 2023.04 Reolink Integration is awesome. (Count me as a sponsor :wink:

I have an Amcrest camera pointing south and Reolink pointing north (back to back).
I don’t like to leave the infrared lights on all the time (too many bugs)
For me the Amcrest provides better (general/dumb) motion detection than the Reolink.
With the new integration I can now better detect objects moving from south to north by turning on the Reolink infrared lights when the Amcrest detects incoming motion from the south.

Still testing, but now I can turn on the house lights “sooner” when driving up to my house. at night :wink:

Good to hear you like it :slight_smile:

If you like to sponsor the reolink integration, you can use Sponsor @starkillerOG on GitHub Sponsors · GitHub, many thanks!

1 Like