Reporting issue enabling I2C on Raspberry Pi 3

Hello,

Having the ability to use I2C was mandatory for me to choose Hassio on the Raspberry Pi 3 (on Home Assistant OS 5.10 32bit). Fortunately I got it working, but not using the official procedure.

The official procedure had me add directories and files to the FAT partition “hassos-boot”, but that wouldn’t enable I2C.

However, following the instruction of dankrill in this post, I figured that the only thing that was missing was to add the line “i2c-bcm2708” in the file: hassos-overlay\etc\modules-load.d\rpi-i2c.conf in partition hassos-overlay
I had to mount the SD card in another computer running linux.
Now my sensors are being read through I2C.

I am posting it for people who google it, so the the will be able to solve the issue in the future, or for the developers to fix the issue so that no one has to search for this in the future.