Repository: NotoriousBDG Add-Ons (Node-RED, HA Bridge, and Gogs)

hassio-repository
Tags: #<Tag:0x00007fd07985d1e8>

#269

maybe the sd card …


#270

Hi

I have problem with node-red-contrib-rfxcom after node-red upgrade to version 0.1.12.

I get error:

Flows stopped due to missing node types.

rfxtrx-port
PT2262-device-list
rfx-PT2262-in
rfx-lights-in
rfx-lights-out

Anyone has this problem?


#271

I use https://www.home-assistant.io/components/rfxtrx/ for my rfxtrx, so I can’t really offer any advice if you’re bypassing Home Assistant.


#272

New install of Hassio 72.1
Supervisor 109
Host Resin 2.3.0+rev1

Your Node-Red add-on never completes install. Any ideas as to what the issue is would be appreciated.

I previously had the community Node-Red add-on installed but only after failing to install your add-on. With the community add-on I was receiving HA API call errors.

The following is logged to system:

6-30 14:41:26 INFO (SyncWorker_19) [hassio.docker.addon] Start build 27e642c6/armhf-addon-nodered:0.1.12
18-06-30 14:41:36 ERROR (SyncWorker_19) [hassio.docker.addon] Can't build 27e642c6/armhf-addon-nodered:0.1.12: failed to register layer: open /var/lib/docker/aufs/layers/e553ed45b5ee0506fd971c0a681562615327b8ce1ca01ff3d9d56505bd6411f2: no such file or directory

#273

Can you check to see if you have adequate free space on your sdcard?


#274

No unix/hass pro but, the way I read this, it looks like I have 88% free disk space:

core-ssh:~# df -h
Filesystem                Size      Used Available Use% Mounted on
none                     28.2G      3.1G     23.6G  12% /
tmpfs                   486.1M         0    486.1M   0% /dev
tmpfs                   486.1M         0    486.1M   0% /sys/fs/cgroup
/dev/mmcblk0p2          294.1M    225.8M     48.7M  82% /dev/init
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /share
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /data
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /config
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /ssl
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /addons
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /backup
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /etc/resolv.conf
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /etc/hostname
/dev/mmcblk0p6           28.2G      3.1G     23.6G  12% /etc/hosts
shm                      64.0M         0     64.0M   0% /dev/shm
tmpfs                   486.1M         0    486.1M   0% /proc/timer_list
tmpfs                   486.1M         0    486.1M   0% /proc/timer_stats
tmpfs                   486.1M         0    486.1M   0% /proc/sched_debug
tmpfs                   486.1M         0    486.1M   0% /sys/firmware

#275

Try to reboot your system then rebuild the addon. If that doesn’t work, you may want to try a new sdcard.


#276

I reimaged the card and installed your add-on first. From there everything seems to have gone smoothly. I don’t believe the issues I was experiencing was due to your add-on… thanks for the add-ones and taking the time to help me troubleshoot.


#277

hello everyone,

I have installed ‘HassOS Release 1 build 5 (Stable)’ on my RPi 3 b+

I am unable to install node-red unfortunately.
All what I get is red flash.
the log file immediately come up with this:

18-07-11 09:50:38 ERROR (MainThread) [hassio.addons.addon] Addon 27e642c6_nodered not supported on aarch64

I’m not sure why

Please help


#278

The add-on isn’t supported on aarch64 platform because there is no official node-red docker image. Try installing the add-on on the 32bit version hassos instead.


#279

I am trying to use the Current State node in Node-Red. However whenever I try and run the automation I get an error: -

Error: Cannot find module ‘…/…/schemas’

Any ideas?

Thanks


#280

Seems that I can’t update some modules:

node-red-node-suncalc
node-red-node-twitter

When I try to update them I get:

Failed to update: node-red-node-twitter

Module not locally installed

Check the log for more information

Other custom modules update correctly.


#281

Attention everyone. I’m not planning to make any more improvements to my add-ons. I’m moving to native docker, so it will be hard to support them going forward. There are other node-red add-ons available that you can use. It looks like Community Hass.io Add-on: Node-RED is the best alternative.

I realize there was a change to hassio supervisor 118 that broke the API proxy. Switching to your connection to use your public hostname instead of http://hassio/homeassistant should workaround the issue until there is a permanent fix.


#282

Thank you @NotoriousBDG, you addon was really fine :slight_smile:
I will migrate my flows to the new addons, if someone needs help doing so I will write a small guide.


#283

I’m getting this error all of a sudden:
npm info it worked if it ends with ok
npm info using [email protected]
npm info using [email protected]
npm ERR! Invalid or unexpected token
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2018-08-10T12_47_16_115Z-debug.log
[ERROR] Can’t install nodes!
but i cant figure out how to open that log file (im using hassio)


#284

Hey @rafuz @NotoriousBDG… I have been using this addon for the last year or so and it was great, now I would like to get all my flows moved over to the community addon made by @frenck but I can’t get this one to start any more, so I can’t figure out how to export my flows… :frowning:

Is there a way to get my flows out of this addons config somewhere through SSH admin console or something… I just don’t know where to look in the file structure. Please help if you can, I have spent so much time building my flows it would be a HUGE waste of time to start over again. thanks!

this is the log I get when I start the addon:

Log
[INFO] Enabling SSL
[INFO] Updating IDE Users
[INFO] Adding IDE User jabroni
[INFO] Updating HTTP Node User
[INFO] Adding HTTP Node User baloneyface
[INFO] Enabling Projects
[INFO] Attempting to install/update nodes: node-red-contrib-home-assistant
npm info it worked if it ends with ok
npm info using [email protected]
npm info using [email protected]
npm ERR! code ENOTFOUND
npm ERR! errno ENOTFOUND
npm ERR! network request to https://registry.npmjs.org/node-red-contrib-home-assistant failed, reason: getaddrinfo ENOTFOUND registry.npmjs.org registry.npmjs.org:443
npm ERR! network This is a problem related to network connectivity.
npm ERR! network In most cases you are behind a proxy or have bad network settings.
npm ERR! network
npm ERR! network If you are behind a proxy, please make sure that the
npm ERR! network ‘proxy’ config is set properly. See: ‘npm help config’
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2018-08-22T19_40_36_105Z-debug.log
[ERROR] Can’t install nodes!


#285

The flows from my addon are stored at /share/node-red, or you can just export them via the UI.


#286

I have been using Notorious Node-Red flawlessly for almost a year, the yesterday I restored my Hassio to 0.81 using a snapshot. After that node red doesn’t want to start. I tried to rebuild it with no luck.

19-03-10 14:26:48 INFO (MainThread) [hassio.snapshots] Restore 4da86667 wait for Home-Assistant 19-03-10 14:26:51 INFO (SyncWorker_1) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.81.0 19-03-10 14:30:44 ERROR (SyncWorker_1) [hassio.docker] Can’t create container from addon_27e642c6_nodered: 404 Client Error: Not Found (“No such image: 27e642c6/armv7-addon-nodered:latest”) 19-03-10 14:30:46 ERROR (SyncWorker_0) [hassio.docker] Can’t create container from addon_27e642c6_nodered: 404 Client Error: Not Found (“No such image: 27e642c6/armv7-addon-nodered:latest”) 19-03-10 14:33:18 INFO (SyncWorker_13) [hassio.docker.interface] Remove Docker 27e642c6/armv7-addon-nodered with latest and None 19-03-10 14:33:18 INFO (SyncWorker_10) [hassio.docker.addon] Start build 27e642c6/armv7-addon-nodered:0.1.12 19-03-10 14:33:23 ERROR (SyncWorker_10) [hassio.docker.addon] Can’t build 27e642c6/armv7-addon-nodered:0.1.12: The command ‘/bin/sh -c apt-get update && apt-get install -y jq && rm -rf /var/lib/apt/lists/* && apt-get clean’ returned a non-zero code: 127


#287

{
“ssl”: false,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“users”: [
{
“username”: “XXXXX”,
“password”: “XXXXXX”,
“permissions”: “*”
}
],
“http_node_user”: [
{
“username”: “admin”,
“password”: “password”
}
],
“projects”: false,
“install_packages”: [],
“install_nodes”: [
“node-red-contrib-home-assistant”
],
“uninstall_nodes”: []
}


#288

Hi 1st I had a issue with Node-Red i reinstalled it and the issue is gone now I had corrupted my SD card again so I reinstalled not both node-red and HA-Bridge is not working I am trying for the last 3 days its not working for me I tried changing my pi my sd card but I don’t know what is the issue i get the same error again and again even in fresh install… please anyone have any idea all other commuinty addon are working only node-red and ha-bridge is not installing even gogs gets installed… or is there any other way to install ha bridge ??
below is the error msg… I am getting… please help!
19-03-17 19:43:39 ERROR (SyncWorker_5) [hassio.docker.addon] Can’t build 27e642c6/armv7-addon-ha-bridge:4.5.6p3: The command ‘/bin/sh -c echo “deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main” | tee /etc/apt/sources.list.d/webupd8team-java.list’ returned a non-zero code: 1