Repository: NotoriousBDG Add-Ons (Node-RED, HA Bridge, and Gogs)

Tags: #<Tag:0x00007fa7418c04e8>

I’ve created a couple of Hass.io add-ons for myself and figured others might be interested. My repo is available at https://github.com/notoriousbdg/hassio-addons.

Current add-ons available:

To add my repo, follow instructions at Installing Third-party Add-ons and add https://github.com/notoriousbdg/hassio-addons.

14 Likes

Hi!

Nice work!

Is it possible to get this for normal Ununtu docker install?

I get this when trying to install Node-Red on my Hass.io Ubuntu install:

17-08-01 06:53:14 ERROR (MainThread) [hassio.addons.addon] Addon 27e642c6_nodered not supported on amd64

@Lajo, done. I don’t have Hass.io on Ubuntu to test with, so please let me know if it works.

1 Like

I refreshed and tested the installer and it installs and runs fine. But I’m on vacations so I cannot test any functionality for a week or so. Nice and speedy work! Thanks a million!

1 Like

I just updated the HA Bridge add-on to fix an issue with Alexa discovering the HA Bridge instance. I also migrated the config files to /share/habridge to make backup/restore easier via samba.

Hi, my first post on this fine forum. Only been using Hassio for a few days and love it! hoping to move across from Indigo. Been using this add on with great success over the last couple days with google home, after this last update however it no longer wants to pair. I’ve added my rasberry IP to the plugin config, but it doesn’t seem to want to play. Any chance in downgrading to the previous release to see is that fixes it. I know there have been issues the connecting the google home, so maybe my luck has just run out?

You can download the older version from https://github.com/notoriousbdg/hassio-addons/tree/412182201d02a2000b81a7f3cb1635eb0a670545. Just place the ha-bridge folder and all it’s contents into a folder named ha-bridge in your addons folder. That will give you a local copy of the addon that you can use.

Thanks, I’ve been installing re configuring and reinstalling different versions, but just can’t seem to strike an gold. I’m not see any errors but it just won’t pair again. Real shame as it was working really well.

I’m not to familiar with docker and why it wanted to use a 172.17 address, when the rasberry nic was a 192.168, but after some reading i realised it a bit like running a vm server. This threw me when i first upgraded to you most recent release as you need to know or know how to find it, where the previous release just went and found the address for you.

strange thing though, and once i realised how to find the docker address, using this address in the current version throws a warning about the ip address (172.17.0.3) not being a recognised host ip. I eventually got this to go away by using a 172.17.0.1 which I assumed was the docker gateway IP. still no joy

When I installed it the first time it just worked with no real setup from me except adding my hassio IP in order to capture my zwave devices. I still have heaps to learn, so have probably messed something up, part of the fun is trying.

thanks for letting me use the previous version anyway to test with.

In the latest version, I changed the container to use host networking, so it has the same IP as the hassio machine. That was needed to get UPNP to work, which is what Alexa needed to discover HA Bridge devices. Supplying the IP of the host is what gets UPNP to advertise the correct IP.

Previously it used the docker bridge network, which is why you notice the 172.17.0.x address. What was happening in the previous version is UPNP was advertising the 172.17.0.x address, which is unreachable.because the 172.17.0.0/16 network only exists on the hassio machine.

Not really sure what could be happening on your system. I noticed my logs showed “Link button pressed…” when I scanned for devices. Also, check out https://github.com/bwssytems/ha-bridge/issues/696 to see if that could be what you’re experiencing.

Well I really don’t know what to say, but YA!! I have success.

This is using the latest version and a clean install of hassio. When I initially installed it and attempted to add the hassio machine IP and started HA Bridge it would present me with the following

If I used the hassio machine IP:
“The upnp config address, 192.168.0.x, does not match any known IP’s on this host”

and If I used the docker address which got auto loaded from previous versions, same again:
“The upnp config address, 172.17.0.x, does not match any known IP’s on this host”

The only one that seemed to get recognised was 172.17.0.1, which I had assumed through my limited understanding of how the dockers worked was some kind of virtual gateway subnet bridging address to the physical. Still didn’t work though.

After reading your response, I went back and had another go at putting in the hassio machine IP again after a fresh reboot of the system and again I got the same above response, but for the docker address??. Now I noticed that the UPNP IP address inside the HA Bridge device management site http://localhost:80 was still showing the previous 172.17.0.x address, so I changed this and restarted the HA Bridge service while in http://localhost:80 and the unknown IP message disappeared and I started seeing a whole lot of encouraging messages in the debug logs.

The tension was palpable :slight_smile: i went into the google home app, paired and ta da!! almost instantly it connected and I’m back.

Now I’ll probably put most of my issues down to staying to far down a rabbit hole learning what hassio has to offer for way too long into the AM for the last few days :slight_smile: I am wondering if the message I was receiving was caused by the HA Bridge service starting before it could see the hassio IP address NIC?? (sure I seen someone else bring this up in another bug report)

Anyhow, thanks for your responses as it really helped me refocus my tests. Now I just need to find a solution to the glitch I have, where I need to request an action twice (either GH or within HA Bridge) after a period of inaction, before HA bridge devices will perform the action.

Loving hassio though and all it has to offer.

Hey @NotoriousBDG so everything now seems to be working rock solid, except for suffering some type of keep alive connection issue, which means i need to say a command to GH once to wake the connection and then again for it to action the request.

example:
1st attempt = Hey Google turn on the kitchen lights = nothing
2nd attempt = Hey Google turn on the kitchen lights = action completed ok

I am seeing the following in my logs not long after i restart home assistant service and am wondering if you know what it could mean?

017-08-06 13:09:44 ERROR (MainThread) [homeassistant.components.light] Error while setting up platform hue
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 164, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=self.hass.loop)
File “/usr/lib/python3.6/asyncio/tasks.py”, line 352, in wait_for
return fut.result()
File “/usr/lib/python3.6/asyncio/futures.py”, line 244, in result
raise self._exception
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/light/hue.py”, line 138, in setup_platform
allow_in_emulated_hue, allow_hue_groups)
File “/usr/lib/python3.6/site-packages/homeassistant/components/light/hue.py”, line 264, in setup_bridge
update_lights()
File “/usr/lib/python3.6/site-packages/homeassistant/util/init.py”, line 303, in wrapper
result = method(*args, **kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/util/init.py”, line 303, in wrapper
result = method(*args, **kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/light/hue.py”, line 182, in update_lights
api = bridge.get_api()

File “/usr/lib/python3.6/site-packages/phue.py”, line 838, in get_api
return self.request(‘GET’, ‘/api/’ + self.username)
TypeError: must be str, not NoneType

I’ve done some quick searches, but i’d be grasping at straws if I was even close to understanding. seem to indicate that the hue.py script is expecting one thing and getting another? It doesn’t seem to be impacting anything though can’t be sure.

Cheers

Edit:
So the more I look at it, the error looks like its referring to credentials not being present. What i’ve noticed with this version is that it doesn’t create a phue.conf file like the last version, which contained the username and pairing or password string. Could this be the issue?

Cheers

1 Like

Hey,
Just installed HA-Bridge in hopes that it would link my Sonoff (Tasmota mod) to Goole Assistant.

How do I configure my MQTT Broker in HaBridge ?

DIdn’t work as planned but in the logs I see the following :

2017-08-06 08:17:21,996 [main] INFO com.bwssystems.HABridge.util.UDPDatagramSender - Initializing UDP response Socket…
2017-08-06 08:17:22,014 [main] INFO com.bwssystems.HABridge.util.UDPDatagramSender - UDP response Seocket initialized to: 50000
2017-08-06 08:17:22,029 [main] INFO com.bwssystems.HABridge.plugins.harmony.HarmonyHome - Harmony Home created. No Harmony devices configured.
2017-08-06 08:17:22,043 [main] INFO com.bwssystems.HABridge.plugins.NestBridge.NestHome - Nest Home created. No Nest configured.
2017-08-06 08:17:22,051 [main] INFO com.bwssystems.HABridge.plugins.hue.HueHome - Hue passthru Home created. No Hue passtrhu systems configured.
2017-08-06 08:17:22,058 [main] INFO com.bwssystems.HABridge.plugins.hal.HalHome - HAL Home created. No HAL devices configured.
2017-08-06 08:17:22,064 [main] INFO com.bwssystems.HABridge.plugins.mqtt.MQTTHome - MQTT Home created. No MQTT Clients configured.
2017-08-06 08:17:22,071 [main] INFO com.bwssystems.HABridge.plugins.hass.HassHome - HomeAssistant Home created. No HomeAssistants configured.
2017-08-06 08:17:22,077 [main] INFO com.bwssystems.HABridge.plugins.exec.CommandHome - Command Home for system program execution created.

@hevolution it looks like you still need to finish configuring HA Bridge. If you haven’t already, goto http://your hassio ip:80 once your in there goto the bridge control and scroll down until you see the MQTT setup section, fill in the blanks and you should be on your way.

@shindawg, Is your Home Assistant trying to discover the HA Bridge emulated Hue? I had to disable discovery of Hue to prevent that from happening. If you have a physical Hue hub, you can add it manually after you disable discovery.

@NotoriousBDG , Brilliant!! thank you, I would never have thought to look at that as being the cause. I can confirm that it has removed/stopped the warning message. Cheers

1 Like

@shindawg, that’s awesome news. I’ll update the readme page warning others of that issue.

Hi. Just installed but won’t start. What is the correct formatting for the server IP field please?

{
  "serverip": null,
  "version": "latest"
}

Disregard. Needed the comma so working now.

{
  "serverip": "10.0.2.12",
  "version": "latest"
}
1 Like

Can you recommend where to learn about integrating HA and node-red?
Is there a go-to thread on this forum?
I see there are a number of discussions and approaches here, just wondering if one is considered to be the best way forward.

thanks

Not sure which way is best. I’m still exploring Node-RED to see how it fits into my Home Assistant environment.