Repository: Ulrar's hassio addons / Forked-DAAPD, raspotify, radicale

Tags: #<Tag:0x00007f738b40f758> #<Tag:0x00007f738b40f3c0>

Nothing happened. I don’t see anything in the add on logs and I don’t think I see in the main ones either

That’s very strange, even if the config was invalid it should still start and error out.
Do you see anything in the hassio system log maybe ?

Absolutely nothing. I’ve been looking all day. And I thought it was my Home Assistant but in the interim, I set up ESPHome and built a sensor. So I’m not sure what’s going on. Maybe I’m completely missing something

My question is slightly off-topic and concerns how you have configured the calDAV integration.

I am experimenting with the calDAV integration and Radicale as well as NextCloud (both installed as Docker containers). Communication is working well. All appointments, birthdays, events, etc that I create, in a single calendar, are displayed in Home Assistant’s Calendar. They also appear in the States view as calendar entities but only if I create a custom_calendar for each category (otherwise only a single entity is created representing the next scheduled calendar entry).

The only problem with creating multiple custom_calendars (that are all based on the same single calendar) is that the Calendar view displays the events multiple times (each event is displayed the same number of times as there are custom_calendars).

How have you configured the calDAV integration to show your events?

Update: Ive been fiddling around and nothing seems to happen when I start the Forked-Daapd add-on. Nothing happens in the logs and nothing is created in the share file. However, Raspotify was able to start and be configured.

NEW UPDATE: It was an issue with a mopidy add on I was messing with and never stopped. Now it opens but wont connect.

NEW NEW UPDATE: It works. Now I just want to configure the spotify - I am getting no artist info using Raspotify. But it works! Also the Ingress does not work.

NEWNEWNEW UPDATE: I can enter credentials for Spotify but I cannot get to the OAuth screen.

Hey, sorry didn’t see your updates before.
Great ! Yes, forked-daapd acts as an MPD server so it’s using the same port as mopidy, I suppose it wasn’t starting because mopidy had the port.

Unfortunately when using raspotify you won’t get any metadata in forked-daapd, that’s because for some reason they’ve been refusing to implement a metadatapipe in librespot.
Someone actually has a PR for it that got refused, so if I have free time at some point (or if someone wants to do it) we could add that code in the addon, probably.

I haven’t tried the OAuth screen through ingress, have you tried connecting directly to the web interface to login ?

Hey sorry for the delay, I don’t actually have it configured in HA because I couldn’t find any decent calendar card. I suppose now that they have that built-in to HA I should try again, I’ll see if I can do that over the WE and update back !

1 Like

So did you mean that custom_calendars show everything in the calendar view, even events that don’t match their search regexp but the sensor only triggers for matching events ?
If so I’m seeing the same thing too, which is indeed very annoying. You can untick calendars in that view but it gets reset when you leave making it pretty useless.

Looks like a bug to me though, the calendar shouldn’t show non matching events in there

That’s correct; Calendar view shows everything and is not limited to the regexp used by custom_calendars.

Being new to the use of the calendar integration and the Calendar view, I found this difference to be confusing. One is able to control what events it shows whereas the other shows all events. The two work independently and that can produce a messy Calendar view with events appearing multiple times.

Than you for confirming that you see the same effect. At first I thought I misconfigured something but now I understand that it’s a “normal” result of the way the integration and view work together (or rather, do not work together).

Hi,
thanks for the addons. I’m having problems with authorising Spotify web API. The redirect URI is forked-daapd.local but forked-daapd.local is not the url of my home-assistant instance. Can that be changed some place?

Hoping someone can help me with a bit of lag. First, I gotta say that this repo is awesome and is exactly what I need for my system.

I’ve got Raspotify + Forked Daapd working and streaming to several speakers, all of them Airplay/Airfoil. But it works great even when I mix in all the Google Homes too…

To my point though, I am getting the following error and wondering what could be done to improve it?

[2020-09-08 10:23:31] [ LOG] player: Source is not providing sufficient data, temporarily suspending playback (deficit=266216/264600 bytes)

I think this is causing my music to have to pause for a couple seconds sometimes.

Any ideas? This is on a Rasperry Pi 4 4GB, everything is network connected.

Hey, sorry for the delay I missed this.

Are you getting that error when playing radios by any chance ? The only (relevant) mention of this I’ve found was when an internet radio had connectivity issues. Is your internet stable, any disconnects when using home assistant while streaming music ?
If that’s when using Raspotify you might want to look at raspotify’s log too, maybe it’s struggling. I did have to rewrite bits of the metadata patch myself and it might not be that stable, you could be running in an issue there.

Could you open an issue on github ? It’d be easier for me to follow than here :slight_smile: