Requirements for tox failing

I’ve just finished a fresh install of the development hass (0.119.0.dev0) in docker and visual studio. I’m trying to run tox for the first time, and I’m getting a package install error for httplib2:

action: py37, msg: getenv
cwd: /workspaces/core
cmd: /workspaces/core/.tox/py37/bin/python -m pip install -r/workspaces/core/requirements_test_all.txt
ERROR: Could not find a version that satisfies the requirement httplib2==0.10.3
ERROR: No matching distribution found for httplib2==0.10.3

The same happens for py38.

If I look at I see it there, but it’s very old. I already have that latest package installed:

$ pip3 install httplib2
Requirement already satisfied: httplib2 in /usr/local/lib/python3.8/site-packages (0.18.1)

I’m new to all this, python, hass, visual studio, docker etc., so I may be doing something stupid. I’m muddling my way through but this one has me a bit stumped. Can anyone shed any light on this?

I followed the solution here: which solved the immediate problem, but then got the same error for package surepy. I tried manually fixing that the same way, tried again, and then got:

The conflict is caused by:
    aiobotocore 0.11.1 depends on botocore<1.13.15 and >=1.13.14
    boto3 1.9.252 depends on botocore<1.13.0 and >=1.12.252

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

I don’t understand this… I thought the docker container was all set up for whatever requirements were needed. Why am I running into all these conflicts on a fresh docker container?

If anyone can shed some light on how I can get tox to complete I’d appreciate it. I have a pull request about ready but can’t submit it because of all these problems.

I’m having the exact same problem. I opened an issue about it on GitHub here:

@mvsjes2 Were you ever able to find a solution?