Restart of HA

I changed the configuration file. And would like to restart HA. But did not find a working solution. Someone a solution.

I’m using the hassbian image.

Have you tried ssh?
sudo systemctl restart home-assistant.service

or if that fails

sudo reboot

Check the log file for errors first though.

I tried it with putty, and tried a sudo reboot but the system didn’t show up after that. (so I tried a clean install because I only had made 5 small changes) and now I’m looking for the solution.

there’s a bug in that version, it has been fixed in the new version of homeassistant released today

Will it update automatically or do I need to do that manually?

You’ll have to do that manually. You should be able to run pip3 install homeassistant -U. I’m not sure of this is the suggested method of upgrading with the Hassbian image, however, you can give it a try.

Note, too, that if you go to the “services” dev tool (icons at the bottom of the left-hand column) in the UI, you can call homeassistant/restart (or /stop for that matter).

I created a few scripts (,, with the correct commands so that I don’t have to remember systemctl every time. Not that the specific restart/start/stop commands will change based on how you installed HA (the All-in-One vs Hassbian, etc).

no option looks like to work.

It usually takes a couple minutes for HA to stop on my Pi3. If you use a command line to restart, you’ll see the command shell wait/hang until HA closes. It’ll return control when HA is starting back up.

Reboot is working for now. But it did freeze for several hours at the first attempt. Then started with clean install.

But the biggest question is how to update HA on HASSbian.

Does the standard option fail?

$ pip3 install --upgrade homeassistant

Long shot but are you using A Raspberry Pi and a wifi adapter? Some wifi adapters have a default sleep setup and can make a pi seem unresponsive from ssh or a front end like HA.

Using a rpi3

Tries it again, but it says all is up to date. But my HA is still giving me the update icon and on one of the screens in still the old version number.

To update Ha on Hassbian
Log in as the pi account

sudo systemctl stop [email protected]
sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 install --upgrade homeassistant
sudo systemctl start [email protected]

@Landrash Thnx!

Wrote up a quick guide that should cover most common questions.

I was having a difficult time to find the restart and log file view of Home Assistant using the Hassbian image.

Here is the commands…

Restart Home Assistant

sudo systemctl restart home-assistant@homeassistant

To view HA Logs

sudo journalctl -f -u home-assistant@homssistant

Hope this helps some one using Hassbian image


Your missing a part of the command

sudo systemctl restart [email protected]

It works for me even with out .service :slight_smile:

1 Like