Restore backup after crash

I’ve been running HA for a couple years but yesterday it crashed. I’ve taken backups now and then and most recent backup is from a few days ago.

I have a raspberry pi 3. Now I do not remember if I used 32 or 64 bit OS before. I flashed and installed the 64 bit latest version as recommended in the getting started guide (my backups are also from using the latest HA version). The system boots up after a few minutes. Then I’ve uploaded my latest backup file and tried to restore it. I tried a couple times yesterday but could not get the system to get to boot up to its gui (it’s available on the network). I then decided to try restore everything except the HA (the option at the very top, not sure of the name). I let the backup restore keep going but still about 7 hours later it has restored some, but not the dashboards or automations or configuration.yaml and many more files, Also, the system keeps reporting lots of errors then that it find a backup file, takes some time, and reports errors and keep repeating.

I use a conbee stick and it was found. The conbee stick was found already before I started the restore of the backup.

I’ve read that a restore of a backup might take some 10 minutes but as stated this takes hours longer. I can open the backup file in my local computer with 7 zip and I see that it contains all my files.

Any suggestions on how to get it back running? I just flashed the 32 bit version and am trying to restore the whole backup.

It works! It works! Wonderful HA.

Flashed the 32bit version to my sd card
Let the system boot up, a few minutes
Uploaded the backup file, seconds
Restored the whole backup, a few minutes

Done! Thank you all.