Restore Backup from 9.5 to 10 not working (how to restore my devices from backup)

I have HA v9.5 and try to upgrade to 10, but it did not work. I formatted my drive with the new version 10. But I can’t do a full restore.

I tried with a fresh copy and where it ask to register or restore from backup. I do tried to restore from backup. It just goes back to the same screen asking me to register account or restore from backup. I let HA run all night long and still same thing.

I also tried doing the new registration and after do upload of backup, followed by restore. Full restore does not work (it freezes), but partial works fine.

The issue with partial, is that it don’t restore my devices. Can some one please help me with restoring my backup or how do I manual restore my devices from backup.

Thank you so much for your support.


I am in the same boat. It is frustrating. Any idea how I would extract at least my config files from the snapshot?

Still no answer for this one? :frowning:

I can’t restore any backups regardless of the version. I am trying on a Pi and a NUC - different and new backups. As soon as I pick the main core home assistant dies and nothing. On the one box I just see its in a freeze state - been like that for hours. I tried the extract and copy over to a new system but way to much to try and redo. Maybe we wait for a fix?

yes, i can confirm that restoring from backups is broken.
i have made a full backup and tried to restore it on a RPI3b+ (coming from 3b)
i have tried restoring it from the onboarding screen (full and partial)
on both accounts HA loses connection and nothing happens. the CLI shows nothing.
i tried restoring a backup from the CLI (backups restore ) but it finshes in about a second. (that should not happen) i also verified if any of the files in the /mnt/supervisor folder had changed or if any of the addons had been restored from the backup. i can confirm that not a single file has been changed after trying to restore the backup.

there are no logs, and i tried to restore a backup from CLI with a debug logging active, but that does not tell me anything. It looks like the restore actions from any backup are broken.
please look into this, as this is a very bad thing.

i have posted a new issue in Github, everyone that is having issues can add to this:

Restoring from Backup broken (full or partial) from both Onboarding page and CLI · Issue #2540 · home-assistant/operating-system (