Restore from older snapshot

Tags: #<Tag:0x00007f73999bc760>

I’ve been using HA for about 1.5 years and always keep it up to date. About a month ago things went downhill and I wasn’t able to open the Supervisor because of a java error. I never was able to take a new snapshot or update since so the latest update I have is from June.

Now when I try to restore this snapshot with a fresh install on an RPi3, it never shows up in the list of snapshots. Yes, I clicked on the refresh button. I tried snapshot refresh from the CLI. I even took the contents of the tar and put them inside a new snapshot (that I took on the fresh install). It looks like there is a different indexing scheme between the new snapshot and the old one.

I’m thinking the next easy thing is to install an older fresh version of HA. But how do I do that? I was probably running 113 and the snapshot was on 0.110.4. I’m guessing the snapshots are scripted to be updated as HA updates, if there is any need to.

Ultimately my question is: What is the easiest way to restore my snapshot?

A couple of questions.

  1. What install method are you using? Supervised or HA OS?
  2. What process are you using to put the snapshot back onto the Pi, and what folder location are putting it in?
  3. Have you tried copy/pasting just the .yaml files from your shapshot back to the new install one by one and seeing if one in particular causes you a problem?
  1. I used Balena Etcher to make the SD image then HA did the rest.
  2. From there I put the old backup in the “backups” folder on the sd.
  3. There are 1400 files in the backup, so no I have not figured out where they all go and copied and pasted them. edit: That was inside the ESPHome.tar, sorry. There are 13 tar’s in the backup but still, I don’t know what to do with them.

If you extract the .tar snapshot, you will get a number of folders/files, one will be named homeassistant.tar.gz. This is the folder that has all of your configuration files, like configuration.yaml, switch.yaml, etc.

If you copy these files individually back to the new install, and then reboot, you may find if one of them has an error, or there has been a configuration change to a component in that file that you will need to update before it will work with 0.114.X.

Thanks, I’ll give that a try. Though it seems like it will leave a few things out, like Mosquitto. It looks like it has a lot of files in many places so I’ll just do my best to dump it everywhere. The backup has files that don’t seem to match with the fresh install with mosquitto addon installed…hmmm. I also don’t see Lovelace.

Trying it now…I’m not getting my zwave things back, which means my life is over. I copied zwcfg_xxxxxxx.xml and zwscene.xml from the backup.

Just do it step by step, don’t stress.

You will need to set up individual add-ons you used previously and some intergrations again, but all of your configuration files will revert to previous.

Thanks for the encouragement. But I have kids and a busy job. I don’t have hours to tinker so this is going to take months to recover step by step.

I’m going to hold out on restoring the snapshot while I spend all my time turning on and off switches by hand. Oh the humanity!