Restore HA - no snapshot

On the beginning of the week, my instance running on a RPi4 suddenly shut down. Unfortunately, I was not able to boot HA again and I cannot understand why. I tried to access the to log file using a Windows software to read the SD content. What I found was this error repeated about 6000 times:
ERROR (MainThread) [pydeconz.websocket] Client connection error
Moreover, I was not able to format the SD that seems to be in a read-only state permanently (I gave it a lot of different tries).
Now I have to re-built my personal HA. For several reasons (the first one is that I’m not really far-sighted), I have no snapshot of my previous installation.
Is there any way to restore my previous HA configuration using the files from the SD card?
This time I decided to try a Virtual Machine installation. has been installed and running. I also installed Samba and I tried to copy all the yaml files into the config folder. Unfortunately it didn’t work.
My greatest problem is that I was running all lights and rolling shutters exploiting the Homekit compatibility of their gateway (Bticino Living Now Smart). The device is now paired to the old installation and it was not possible to find it again to be associate without an hard reset. To do that, I have to remove all the devices and then add them again.
If there is a way to avoid that, I would be more than happy to follow.
Any hope over there? :slight_smile:

There should be a (hidden) folder named .storage
That folder should contain all your devices and entities
Fair change you can copy that folder :wink:

Thank you for your help! Actually this helped because all the entities appeared in the new installation. Unfortunately, they don’t work at all. Neither the state is reading correctly.
I’m start thinking that I cannot be saved from a fresh installation. :frowning: