Restoring snapshot not working


#1

Hi, my SD-card crashed the other day and I’m trying to restore one of my snapshots to a new one.
Flashed the latest Hassio image to my new card, installed smb, added my snapshots to the backup folder and started restoring. However, all that happens is that everything just dies. Hassio dies, smb dies and the only thing that works is pinging the raspberry on which I’ve installed Hassio. While pinging is fun and all, it doesn’t give me my Hassio setup back. I’ve tried three different backups now and not a single one works. I’ve never had trouble restoring snapshots from within Hassio before but this is the first time I try it on a fresh install.
Am I doing something fundamentally wrong or what?


#2

Have you had a look inside the backup files? Do they contain your yaml files?

What caused the crash? Are you trying to restore a corrupt or invalid configuration (I guess not as you said you tried a few different ones)?

The next thing to try is to extract the yaml files from the backup and restore manually by copying them across and then setting everything else up (addons, integrations etc…). Bit of a PITA but better than starting from scratch.


#3

They contain my YAML files and they are intact and looks like they should.
I don’t think I’m trying to restore a corrupt snapshot because I have, as you mentioned, tried a few different ones.

Can you explain in more detail how I would go about doing that? Would it be as “simple” as just installing all my addons to get the correct folders and then just copy and paste all the files over from my snapshot to my hassio installation?


#4

Yes,

Install the SAMBA addon (and any others you use) then copy across the contents of your config folder. Well it used to be that simple. I’m not sure about the .storage folder contents. I’m guessing it should be ok to do. Worth a try.

Restart.

Then go to configuration / integrations and set them up.


#5

I managed to get a log out, detecting errors with the built-in mqtt broker. Manually removing everything related to mqtt through samba After i’ve restored my backup got everything up and running again (except for mqtt).


#6

Hi,

How did you managed to get the log? It looks like I am having a similar issue.