RF Bridge with Tasmota Error Code

Hi All,

I have already flashed my Sonoff RF Bridge 433MHz with the latest Tasmota and made it working with my Door and Motion sensor over MQTT.

I want to be able to create automation upon RF Data code.
I configured this in configuration.yaml

  - platform: mqtt
    state_topic: "tele/RF_Bridge/RESULT"
    name: "House Door"
    value_template: "{{value_json.RfReceived.Data}}"
    payload_on: "EB57F2"
    payload_off: "EB57F2off"
    device_class: door
    optimistic: false
    qos: 1
    retain: false

That Sensor ONLY have one Data code so I have added a dummy code for off.
Here is an image of my MQTT explorer:

The code is in that topic I configured exactly.
But when I ran the checker for my configuration I am getting an error:

Error: Testing configuration at /config
Failed config
    - Invalid config for [binary_sensor.mqtt]: [optimistic] is an invalid option for [binary_sensor.mqtt]. Check: binary_sensor.mqtt->optimistic. (See ?, line ?). Please check the docs at https://home-assistant.io/integrations/mqtt/
    - platform: mqtt
      device_class: door
      name: House Door
      optimistic: False
      payload_off: EB57F2off
      payload_on: EB57F2
      qos: 1
      retain: False
      state_topic: tele/RF_Bridge/RESULT
      value_template: {{value_json.RfReceived.Data}}

Successful config (partial)

I have being trying to make it running with no luck at all.
I would be happy to get assistant on what I am MISSING - surely I missed something here But I do not know what.

Please assist on how to make it work?

Please read this topic :

1 Like

Thank you Francis

I have worked with strategy number one and I have made it work Right away!!
Even though I neglected my first code using a dummy code etc… I am NOW sure that the one you gave me is the Correct way to work with the binary Sensors and even unary Sensors

I am now continuing all my RF sensors that way.
thanks for sharing that link. :clap: :slightly_smiling_face: