RF issue? Barely able to pair with battery powered devices. Assymetric LQI

Hi all,

I have been using HomeAssistant for around a week now. I am very pleased with the platform and have found the community very helpful so far.

There is one issue that I have been unable to fix thus far:
My Zigbee (Sonoff ZBDongle-P) coordinator has great difficulty pairing with battery powered devices (from Ikea). Also binding and OTA don’t work (except for 1 sensor, where binding succeeded after many attempts). Once paired, the sensors and remotes work just fine. Also AC powered devices like lamps and smart sockets pair just fine.

I found that there is a specific spot in my house that works somewhat (with around 25% chance of success). That spot is about 4 meters away from the antenna. If I come too close then pairing will fail, if I go to far then pairing also fails. (In the paring GUI, the blue window gets stuck at interrogating or something similar, forever, it never turns green. If I abort at that point, then I end up with a Zigbee device without any capabilities).
One remote (Ikea on/off switch) was so bad that it took over 10 attempts to pair.

When I look at the visualization of my Zigbee mesh, then I notice that the coordinator’s LQI numbers are very assymetric (one LQI is 1/2 to 1/3 of the other LQI).

Is suspect that the following two things are going wrong:

  • The transmit power of my stick is too high, while the receive sensitivity is too low.
    (this would explain the very specific distance for pairing and the asymmetrical LQI; Too close and the receiver antenna gets over saturated, too far and the responses are not received)
  • The pairing communication is not coming in via the mesh, only directly to/from the coordinator.

Is this normal behavior, is my stick defective or am I doing something wrong?
Now I am dreading the day that I have to re-do a pairing. Also I cannot make my setup robust by binding the remotes to groups of lamps (I want my lights to remain functional even if HA is down for some reason). And I can never update my remotes this way…

btw, my ZBDongle-P is runnning firmware version “Z-Stack 20230507”, that I grabbed from Koenkk’s GitHub Z-Stack-firmware/coordinator/Z-Stack_3.x.0/bin/CC1352P2_CC2652P_launchpad_coordinator_20230507.zip at 245509ce59320bf2a08e3131b519d824ecb0066c · Koenkk/Z-Stack-firmware · GitHub

How many router (mains powered) devices do you have? One thing that might help is to pair to the nearest routing device as opposed to the coordinator itself.

Thank you for replying.

I had not spotted the “Add devices via this device” option. I just successfully paired a remote in the first attempt :slight_smile:
(I previously used the “add device” button underneath the Zigbee device list)

However binding still does not work. The binding settings do appear to get set (the “bind group” button lights up green with a checkmark) however the binding does not appear to work. Pressing a butting while binding accelerates the process (I am assuming the remote listens in only every now and then, and after an event).

Binding remotes is not a fun task… but generally, yes, when binding a remote, it’s best to push a button on the remote about every second during the binding process.

Just found that binding to groups just does not work. Binding to individual devices does.
Is this an Ikea limitation? (assuming the binding is stored in the remote).

Also, does all communication to a battery powered device pass through the router that was used during pairing? Or is this also an Ikea quirk?

Yeah, I think that’s actually a limitation in ZHA. In Zigbee2MQTT, you can bind to a group.

The binding is stored with the coordinator and will usually determine the best route based upon the mesh performance.

Thank you for answering, it was very helpful :slight_smile:
I marked your answer as the solution.

1 Like