Rflink & groups + restart HA

I’m just starting with HA ( yes again ) and having some trouble to understand rflink integration.
I have added all the devices to there groups, customize etc sections and everything is working.
Though I have 2 problems i can’t seem to understand.

1 ) How can I remove the light group and only show them in there right group “ex. keuken”
2) when i restart HA all groups and entities are gone from the frontend. when i press the button on the remote they are back to the frontend. How can I force HA to remember there group ( I understand HA can’t remember there state, so this is fine ) and show them always on the frontend.

– passie

Im no expert but i think u have to play around with the default_view option.

    view: yes
    icon: mdi:home 
      - group.kitchen
      - group.awesome_people
      - group.climate

Then it will only show the groups u want to show.

Bare in mind that this will disable HA to autoadd stuff to the UI, i solve this with view: no when i configure stuff, and then change it back to view: yes when im done.
Dont now any other way, im new to HA also.

thank you for your answer.

I have created groups for the entities which I would like to see, Though when i don’t press a button the group is empty and shows “unknown”

it’s strange that the lights are visible in the light group without pressing a button, which i didn’t created manually but not in there assigned group.
So this is something coming from the component of RFlink.
Before restarting HA should save the state of each device for later use, but this would require a some coding on the component part.

Would be nice if I could hide the light group.

have u tried

  hidden: true

To good to be true

homeassistant.config] Invalid config for [group]: [hidden] is an invalid option for [group]. Check: group->group->light->hidden

hmm try this in your customize.yaml file

  hidden: true

or whatever your Entity name for that group is.

Well the error is gone but the light group is still there :slight_smile:
I tried:

  hidden: true

as well:

  hidden: true

well, then i don’t know :frowning:

maybe @aequitas could shed some light on this? :blush:

For hiding groups you need to use the customize feature afaik: https://home-assistant.io/docs/configuration/customizing-devices/

For permanent configuration of Rflink devices you need to add them to the configuration as Rflink devices. Adding them only to groups is not enough: https://home-assistant.io/components/light.rflink/

Maybe I didn’t explained my self well.
The problem is that all rflink devices get populated in the light group after a restart.
These devices are added in the devices: section like you mentioned.

After I press a button on a physical remote the devices get populated to the right group like “keuken” in my screenshot.

The second part is that it’s ( i think ) impossible to hide the light group from the view since all devices which are not beloning to a group ( see question 1 ) are getting populated in this group.

But please correct me if i’m wrong.
Below is a snippet from my configuration.yaml which I have so far.


- platform: rflink
  automatic_add: True
    fire_event: true
    signal_repetitions: 2
      name: KeukenLamp
      name: Woonkamer voor
      name: Woonkamer achter
      name: Tuinverlichting
      name: Tuin wandlamp
      name: woonkamer bank


  - light.kaku_000041_1

– passie

You should add the devices to the group with their name and not their id. So try adding light.keukenlamp instead of light.kaku_000041_1.

Or automatic_add: False?
I Only use true when adding stuff

Grrrrrr, I didn’t know you had to add the names and not the id.
the devices are now put in the right group with a default flash light switch.

though when switching a light it still get populated again in the light group.
Something else i’m doing wrong ?

Light > Keukenlamp & Keuken > Keukenlamp are the same entities.
Though only the one in the light group is working.
I tried different types as explained on the component page but this didn’t help.

note: Bureau is a yeelight and not a rf so this is a different light type

figured it out.

instead of:

name: KeukenLamp
type: switchable

I had to use:

name: KeukenLamp
type: switchable

Hope this helps somebody else.
now figure out how to change the type ( icon ) from lightning to toggle

Why is the

assumed_state: false

not working for RFlink lights, still getting the flash light icons ?