RFlink show's: cannot call service light.turn_on

Hi there,

Trying to get rflink working on a RP4+4gb. Have the same setup on a Brix (kind of a NUC), without any problems, but now, can’t get it to work.

In logfiles it shows:

Logger: homeassistant.components.websocket_api.http.connection.2962889792
Source: components/rflink/__init__.py:524
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 13:10:07 (1 occurrences)
Last logged: 13:10:07

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 125, in handle_call_service
    await hass.services.async_call(
  File "/usr/src/homeassistant/homeassistant/core.py", line 1308, in async_call
  File "/usr/src/homeassistant/homeassistant/core.py", line 1343, in _execute_service
    await handler.func(service_call)
  File "/usr/src/homeassistant/homeassistant/helpers/entity_component.py", line 208, in handle_service
    await self.hass.helpers.service.entity_service_call(
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 454, in entity_service_call
    future.result()  # pop exception if have
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 583, in async_request_call
    await coro
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 485, in _handle_entity_call
    await result
  File "/usr/src/homeassistant/homeassistant/components/light/__init__.py", line 249, in async_handle_light_on_service
    await light.async_turn_on(**params)
  File "/usr/src/homeassistant/homeassistant/components/rflink/light.py", line 248, in async_turn_on
    await self._async_handle_command("dim", self._brightness)
  File "/usr/src/homeassistant/homeassistant/components/rflink/__init__.py", line 498, in _async_handle_command
    await self._async_send_command(cmd, self._signal_repetitions)
  File "/usr/src/homeassistant/homeassistant/components/rflink/__init__.py", line 524, in _async_send_command
    await self._protocol.send_command_ack(self._device_id, cmd)
  File "/usr/local/lib/python3.8/site-packages/rflink/protocol.py", line 227, in send_command_ack
    yield from asyncio.wait_for(
  File "/usr/local/lib/python3.8/asyncio/tasks.py", line 490, in wait_for
    raise exceptions.TimeoutError()

I’m running it on Raspbian Buster with Supervisor in docker (like my brix too). Tried also a original image for Pi4, but got same message/problem.

You did select the correct serial port ?

Yeah, But i think its the arduino(rflink) which is the problem. I have another RFlink which works perfectly (i just tried it). The L led is blinking on the other rf link. So i think i’ll contact the webshop with this problem.

This topic may be closed now.

Omg. I now remember that i had to flash the arduino first i think. I saw something about R48 firmware. Jeez, i spent hours last night to fix this, but i couldn’t.

Pffff… i need a holiday i think.

Yes, flashing is indeed required :slight_smile:

Yeah. Flashed, and working perfectly now. Thanks for rubberducking!