RFLink Somfy cover moves only a bit

Dear Community,

i managed to get the RFLINK Gateway from nodo to work. so i successfully connected all my covers with RFlinkLoader and configured the covers as follows:

  - platform: rflink
        name: somfy_living_room
          - rts_95c044_01
        name: somfy_kitchen
          - rts_96c044_01
         name: somfy_office
          - rts_93c044_01
         name: somfy_bedroom
          - rts_94c044_01

When i trigger a command (UP/DOWN) the cover react, but it moves only a bit. when i click up/down with the remote it goes up/down completely. is this normal? do i have to configure something specific?
As it is now it’s not usable, as i would need to trigger DOWN 10 times until the cover reached the bottom. wait_for_ackmade no difference and signal_repetitions is no option either, as it pauses after every movement (~20 cm).

Hope someone has a similiar experience and can help me in the right direction.

Thanks a lot

i now also tried different firmwares. first the newest R48 - and after the R46, as it is described as the tested firmware in https://www.home-assistant.io/integrations/cover.rflink/.

sadly the result is the same, the blinds only move for a few seconds and then stop.

this is an example log of a down command:

2020-04-19 08:13:21 DEBUG (MainThread) [rflink.protocol] sending command: {'protocol': 'RTS', 'id': '333333', 'switch': '0', 'command': 'DOWN'}
2020-04-19 08:13:21 DEBUG (MainThread) [rflink.protocol] writing data: '10;RTS;333333;0;DOWN;\r\n'
2020-04-19 08:13:21 DEBUG (MainThread) [rflink.protocol] waiting for acknowledgement
2020-04-19 08:13:24 DEBUG (MainThread) [rflink.protocol] received data: 20;2B;OK;
2020-04-19 08:13:24 DEBUG (MainThread) [rflink.protocol] received data: 
2020-04-19 08:13:24 DEBUG (MainThread) [rflink.protocol] got packet: 20;2B;OK;
2020-04-19 08:13:24 DEBUG (MainThread) [rflink.protocol] decoded packet: {'node': 'gateway', 'protocol': 'unknown', 'ok': True}
2020-04-19 08:13:24 DEBUG (MainThread) [rflink.protocol] command response: {'node': 'gateway', 'protocol': 'unknown', 'ok': True}
2020-04-19 08:13:24 DEBUG (MainThread) [rflink.protocol] packet acknowledged

i tried out different device ids (read somewhere they need to be close to the original) and different switch channels. sadly nothing helped. they still stop moving afte ~2/3 seconds.

Once covers starts moving there is no reason why it would stop. Your logs seems good to me.
There are other logs when cover stop? Any automation in HA?

No one of this reason seems probable to me, but have you verified that something of this is not happening?:

  • cover in pairing mode
  • setting upper/lower limit mode

there are no other logs after they stop. the example above is everything that gets logged.

its actually a pretty clean and new HA installation. so no automation, scripts, scenes, … i just have connected my samsungtv with the integration and installed and configured alexa (haaska). other than that only my RFLink with the covers.

during pairing with RFLinkLoader everything went normal i guess. after paring mode the cover switched shortly. after the pair command again and i got ok back.

what do you mean with

setting upper/lower limit mode

is there another step not mentioned in the documentation? (RFLink Cover - Home Assistant)

I was wondering if there are any logs when it stops.

From your remote (the physical one) there are some cover settings that you play with. One of them are the upper and lower limit. You can read about it here:

When cover is in “programming mode” it does not move continuously, but the same would happen within HA or the remote.

I’ve come across some reports with problems like yours, but there are no solutions at all.

I am sorry not to be of more helpfull

there are no more logs after it stops than i sent above.

ah, as up/down on the physical remote are going completely up and down i guess settings were programmed correctly. but i’ll definetly try out overwrite them or at least play around with them.
in the video they say if a blind is part of a group (i have a telis 4 remote with 5 channels and 4 blinds) i have to disconnect every other blind except the one i want to program before i play around with those settings. but i cannot really get to the power access of the others, do you mean i still can program those settings as described in the video, without unplugging the others?

well, you already gave me one tip that i can now try. i’m grateful for that - thank you :slight_smile:


That’s the same as I think.

I think it should be possible. The problem you may have is that when you try to put the cover in programming mode, it activates in more than one cover you want to program and you end up having strange effects.

If cover reacts as expected with remote but works weird with HA there will be another problem.
Can you try to config and pair a new remote code? This time use a device code more similar to the remote one, something like rts_94c048_01 or maybe rts_94c064_01.

By the way, the aliases part in the post is the real one? Are all overs controlled with the same remote rts_94c044_01 ?

Another question, are you using an specific Somfy RFLink?
I mean, ‘normal’ RFLink is an 433,92Mhz device, and Somfy covers works in 433,42Mhz. Are you aware of this?

I think that would rather cause a problem in signal sending and not that kind of behavior, but…

ill try it and will report if setting the top and bottom standard helped - i can try it out tomorrow.

i already tried this, because i read it in some forum. i only changed the last digit of the hex code - sadly had the same result.

all covers are controlled with the same remote (telis 4). each channel controlls its own cover. the last channgel controls all of them together. each alias is different and has its own device id as you can see in the config.

yes im aware of that. this is why i bought the recommended device from the nodo shop. specific for somfy rts devices in the 433,41Mhz zone. this is the device i use: RFLink 433 (Somfy RTS) / Arduino / Dipole / USB cable

another thing i noticed is, that when flashing the rflink R48 firmware it always says V1.1 - R48 and in the documentation of rflink on HA it says it was tested on V1.4/RFLink R46. is that a mistake in the documentation? i did not find any v1.4.


I really don’t think that’s the problem.

Upss, I had not noticed before, I was only looking at the channel part. My mistake.

This is the same log that I see. I suppose it is an error in the documentation.



Same guy, another forum:

hi javicalle,

so after playing around a bit more and dozens of clearing, resetting and pairing i’ve got it at least to work a bit better. they still dont go completely up and down, but at least they move way longer now.
The change that made the difference was toggling 10;RTSLONGTX; to ON.

So i configured signal_repetitions in the device_defaults to 2.

Thats not the final solution, but one that i can live with for the next time. I’ll come back later if i have some more freetime to do so.

Thank you once again for your help so far :slight_smile:

hi dseidl,

have you tried to change your covers from US-mode to EU-mode? at the beginning of my configuration with rflink and somfy covers i experienced the same problem. after switching each blind/cover to EU-mode this behavior was gone.

hi tamwoe,

first thank you for your help.

How do i change my covers to EU? is it a rflink command or a home assistant configuration? i couldn’t find any info in both documentations.


neither one of them! you have to configure your cover with your original somfy remote. my blinds. to switch between US and EU mode you have to simultaneously press UP and DOWN on your remote for 5 seconds. cover should move up/down. the you press MY and DOWN simultaneously for 2 seconds. cover moves again! this should switch modes.

1 Like

i’ve just changed the mode of all my covers. and that was it. :partying_face:

i turned off longtx again, and now the covers move completely up and down with one command, and i can use the stop comand as expected (that wasn’t the case with longtx before). thank you two so much! @tamwoe & @javicalle

You‘re welcome :wink: .

Wow! Really? Thats great!
How did you know about that configuration? Do you have a link to any official documentation?

I found that information in a pdf document. That was a manual of my blind motor (J406 RTS). In one chapter it‘s mentioned that the motor is in US mode by factory default and with the above method you can switch between US and EU mode and reverse. In US mode a short press of the UP and Down button makes the cover go up or down completely. A long press configures the tilt. EU mode is the opposite. A short press configures tilt and a long press makes the cover go down or up completely. Here‘s the manual but it‘s in german: