Rfxcom not accepting Gira-Jalousie as Event-code

Hi All,

i wanted to control my Gira-Jalousie with HA but am not able to add them as event. What i did so far:

My System is a Raspi4 where i installed Home Assistant on top of the raspbian image

  • Install RFXCOM RFXtrx: [RFXCOM RFXtrx - Home Assistant]

  • My RF-Device RFXtrx433XL is detected and RFXCOM is installed.

  • on my windows machine i installed the rfxmanager from the offical page [Downloads] to check for the signals. From there i´m able to receive and control the Gira Funkbus

28.01.2022 09:55:25:276= FunkBus command: 0B 1E 00 17 3F CC 42 04 00 02 00 09 
Packettype    = FunkBus
subtype       = Gira Remote
Sequence nbr  = 23
ID            = 3FCC decimal:16332
groupcode     = B
channel       = 4
Command       = Channel -
Command time  = very long press 1,25 sec
Battery       = OK
Signal level  = +10 dBm
28.01.2022 09:55:26:852= 0402011700
Packettype        = Receiver/Transmitter Message
subtype           = Transmitter Response
Sequence nbr      = 23
response          = ACK, data correct transmitted

It works like a charm and therefore i wanted to implement this into Home Assistant

I tried to enter the FunkBus command: 0B 1E 00 17 3F CC 42 04 00 02 00 09 as EventCode but it is rejected with “Invalid event code”. I then looked around and found some working codes (09190307 6C911A000070 or 0b11009e 00e6116202020070). When i enter these codes as event they are accepted. This is great because it shows that there are some checks but i was not able to figure out, how i should change my code to be accepted.

When i see it right, RFXCOM is “seeing” what kind of device i added with the event code, but i was not able to find a list of all these codes.

I really hope someone can help me with this and i hope i set the correct format :wink:

Have an awesome day

Maybe you did but cannot see this…did you try to set HA rfx integration to auto-add? Or, why manual if HA can do this for you?

1 Like

Hi @vingerha,

thx for your answer. I set the rfx on auto-add, but it did not detect any signal regardless if i press the remote (GIRA 052700) or the button on the wall (Gira). Btw. i did´t receive a signal from a cheap RF-Remote as well, i detects nothing right now ;(

My configuration.yaml looks like this:

# Configure a default setup of Home Assistant (frontend, api, etc)

# Text to speech
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
#switch: !include setting/switch.yaml

 device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433XL_DO5P0AIP-if00-port0
 automatic_add: true

  default: error
    homeassistant.component.rfxtrx: debug

Originally i had the logger identical to the instructions on HA:

    RFXtrx: debug

Regardless the configuration, i did not get any signal in the autodetect and because of that i thought i add it manually but as stated in my comment above it did not work either. Would be great if you have some ideas what i could try next :wink:

If anybody has GIRA in use it would be great to see the ID of the shutter so i can learn how the codes could be accepted.

Thanks all and have a great day

And can you see the signal coming in using RFXmngr?..i.e. is it in a mode to receive things

Hi @vingerha,

yes, in RFXmgr on my Windows10-Client i can see and send the signals. For the GIRA-Shutter it was a bit complicated, i had to set my wall mount to “learning” mode and send the signal from rfxmgr. Now i can control the first shutter and could do this for all the other shutters.

I activated the funkbus and saved it and when i unplug and plug it shows funkbus as activate so i “hope” that it is activated when i plug it in the raspberry pi.

I see… I did similarly with my ‘somfy’ garage door, I had to generate the signal coming form RFX, I used the RFY tab and ‘program’…similar as you did I guess… not sure if you already looked at the Somfy chapter in here … RFXCOM RFXtrx - Home Assistant

Hi @vingerha,

yeah i looked at the Somfy Chaper. I tried to use this chapter:

The RFXtrx433e or later versions like RFXtrx433XL is required for support, however, it does not support receive for the Somfy RTS protocol - as such devices cannot be automatically added. Instead, configure the device in the rfxmngr tool. Make a note of the assigned ID and Unit Code and then add a device to the configuration with the following id 071a0000[id][unit_code] . E.g., if the id was 0a 00 01 , and the unit code was 01 then the fully qualified id would be 071a00000a000101 , if you set your id/code to single digit in the rfxmngr, e.g., id: 1 02 03 and unit code: 1 you will need to add 0 before, so 102031 becomes 071a000001020301 .

I used the 071a0000 and after that i posted the Code i extracted from RFXmgr 3F CC 42 04 00 02 00 09 to add this as a new event code but i receive “Invalid event code”.

So… my complete is
basis: 071a0000
ID: 01 08 08 (in rfxmgr it shows as 1 08 08
Unit code: 01 (in rfxmgr it shows as 1)
so in total: 071a000001080800

Hi @vingerha,

do you use FunkBus in RFXmanager? I´m not sure about the unit code because i have a group code, a command and a channel.

Thanks a lot for your help!

Nope…using RFY … so seems running at a dead-end now
I found an old topic with little hope: RFXtrx not working with Gira Funkbus? - sendor id not showing/debug remains empty · Issue #27446 · home-assistant/core · GitHub
Just as info… whatever I enter in HA, e.g. 071a000001080800… in rfxmngr it does not show as RFY so quite hard to analyse. I am sorry to not be of more help

I had similar issues with my switches. Worked fine with the RFXmngr in Windows but I could not figure out what event code to use in HA. What eventually worked for me is to use RFXmngr at 433.92MHz (it automatically switches to .42 for Funk Bus), with an ANSLUT device:

In this case you can use 0B11020C00003FCC01010000 in HA as event code. The 4th byte (0C) is the Sequence nbr but you can leave this as 00. Just see what the RFXmngr generates for the ANSLUT device for your Group and Unit as per the RFXtrx User Manual.

Just an additional note: I still program the Funk Bus devices with RXFmngr using the FunkBus tab, as for programming you need to be able to set the minimum signal time to 2s.

Interesting…and my 2cents … maybe also the RFY setup can be used as a workaround…as I have no Gira/Funkbus

And I just received this one… it will require some tech stuff and not even sure if it will serve your purpose. But…since you could wait for a long time before Gira gets implemented…maybe this is worth looking at

I solved my issue (had all the entries in yaml which is unsupported by the RFXTRX integration now (2023)).
First i copied/saved all the yaml entries to a text file. Then removed the existing rfxtrx integration, then re-installed it and started adding each of the yaml entries as “undecoded”. this seems to work fine for Kika -
Testing Gira/Anslut/funkbus also works.

Note that for Gira/Anslut you will probably need custom firmware (to be requested from the RFXTRX manufacterer).

So just to make sure this gets stored/logged: tthrough the rfxtrx configure menu item you add “undecoded” event code (like “0B11020101003FCC05010C00” as captured using the RFXTRX tool on you pc when issuing command). just click submit, submit, finish. In my case is see the following device appear: ANSLUT 1003fcc:5

Just rename this and you are good to go. Remember - you are talking to an analog system using unsupported software/hardware - hence you might need to send the same code twice/three times to get Gira to respond properly (in my case i have to send the code twice to turn the light off).

Be sure to store the command codes somewhere as i have no idea if you can recover them in the future (i used to have them in my yaml file for past configs, so i grabbed them from there)